{"answers":{"affected":"2 open source packages ship an affected version, including @apollo/experimental-nextjs-app-support. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-23841 in the wild and no public exploit code.","fix":"Upgrade @apollo/experimental-nextjs-app-support to 0.7.0 or later.","what":"CVE-2024-23841 is a high-severity cross-site scripting vulnerability in apollographql apollo-client-nextjs, published on 30 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-23841 and fix it if it is affected.\n\nWhat it is: CVE-2024-23841 is a high-severity cross-site scripting vulnerability in apollographql apollo-client-nextjs, published on 30 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-23841 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @apollo/experimental-nextjs-app-support (npm): affected all versions; fixed in 0.7.0\n- @apollo/experimental-nextjs-app-support (npm): affected all versions; fixed in 0.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-23841/ (Markdown: https://insights.sbomify.com/CVE-2024-23841/index.md)","id":"CVE-2024-23841","markdown":"https://insights.sbomify.com/CVE-2024-23841/index.md","name":"CVE-2024-23841","record":{"aliases":["GHSA-rv8p-rr2h-fgpg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apollo Client Next.js","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in the victim's browser via malicious input in Apollo Client for Next.js.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"apollo_client","vendor":"apollographql"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"}],"description":"apollo-client-nextjs is the Apollo Client support for the Next.js App Router. The @apollo/experimental-apollo-client-nextjs NPM package is vulnerable to a cross-site scripting vulnerability. To exploit this vulnerability, an attacker would need to either inject malicious input (e.g. by redirecting a user to a specifically-crafted link) or arrange to have malicious input be returned by a GraphQL server (e.g. by persisting it in a database). To fix this issue, please update to version 0.7.0 or later.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XSS in @apollo/experimental-nextjs-app-support","id":"CVE-2024-23841","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Hitron Systems DVR LGUVR-16H Improper Input Validation Vulnerability","id":"CVE-2024-23842"},"packages":[{"ecosystem":"npm","fixed":["0.7.0"],"introduced":["0"],"last_affected":[],"package":"@apollo/experimental-nextjs-app-support","purl":null,"source":"GHSA-rv8p-rr2h-fgpg"},{"ecosystem":"npm","fixed":["0.7.0"],"introduced":["0"],"last_affected":[],"package":"@apollo/experimental-nextjs-app-support","purl":"pkg:npm/%40apollo/experimental-nextjs-app-support","source":"GHSA-rv8p-rr2h-fgpg"}],"prev":{"headline":"`goreleaser release --debug` shows secrets","id":"CVE-2024-23840"},"products":["apollo-client-nextjs"],"published":"2024-01-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-17","vendors":["apollographql"]},"summary":"An attacker can execute arbitrary scripts in the victim's browser via malicious input in Apollo Client for Next.js.","url":"https://insights.sbomify.com/CVE-2024-23841/"}