# CVE-2024-23841: XSS in @apollo/experimental-nextjs-app-support

> An attacker can execute arbitrary scripts in the victim's browser via malicious input in Apollo Client for Next.js.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-rv8p-rr2h-fgpg

## What is CVE-2024-23841?

CVE-2024-23841 is a high-severity cross-site scripting vulnerability in apollographql apollo-client-nextjs, published on 30 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

apollo-client-nextjs is the Apollo Client support for the Next.js App Router. The @apollo/experimental-apollo-client-nextjs NPM package is vulnerable to a cross-site scripting vulnerability. To exploit this vulnerability, an attacker would need to either inject malicious input (e.g. by redirecting a user to a specifically-crafted link) or arrange to have malicious input be returned by a GraphQL server (e.g. by persisting it in a database). To fix this issue, please update to version 0.7.0 or later.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2024-23841?

2 open source packages ship an affected version, including @apollo/experimental-nextjs-app-support. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@apollo/experimental-nextjs-app-support` | npm | All versions | 0.7.0 |
| `@apollo/experimental-nextjs-app-support` | npm | All versions | 0.7.0 |

Products: Apollographql Apollo Client.

## How do I fix CVE-2024-23841?

Upgrade @apollo/experimental-nextjs-app-support to 0.7.0 or later.

## Is CVE-2024-23841 being exploited?

There is no known exploitation of CVE-2024-23841 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23841 and fix it if it is affected.

What it is: CVE-2024-23841 is a high-severity cross-site scripting vulnerability in apollographql apollo-client-nextjs, published on 30 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23841 in the wild and no public exploit code.

Affected packages and fixed versions:
- @apollo/experimental-nextjs-app-support (npm): affected all versions; fixed in 0.7.0
- @apollo/experimental-nextjs-app-support (npm): affected all versions; fixed in 0.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23841/ (Markdown: https://insights.sbomify.com/CVE-2024-23841/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23841
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23841
- OSV: https://osv.dev/vulnerability/CVE-2024-23841

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23841/
Summaries are generated and may contain mistakes; the official description above is the record.
