# CVE-2024-23898: Cross-site WebSocket hijacking vulnerability in the Jenkins CLI

> Attackers can execute CLI commands on Jenkins controllers via cross-site WebSocket hijacking due to missing origin validation.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jan 2024
- **Updated:** 20 Jun 2025
- **Also known as:** BIT-jenkins-2024-23898, GHSA-53ph-2r2x-vqw8

## What is CVE-2024-23898?

CVE-2024-23898 is a high-severity vulnerability in Jenkins Jenkins, published on 24 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jenkins 2.217 through 2.441 (both inclusive), LTS 2.222.1 through 2.426.2 (both inclusive) does not perform origin validation of requests made through the CLI WebSocket endpoint, resulting in a cross-site WebSocket hijacking (CSWSH) vulnerability, allowing attackers to execute CLI commands on the Jenkins controller.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2024-23898?

7 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | None |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | None |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.217 | 2.426.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.217 | 2.426.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.427 | 2.442 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.427 | 2.442 |
| `jenkins` | Bitnami | From 2.217.0 | 2.452.1 |

Products: Jenkins Jenkins.

## How do I fix CVE-2024-23898?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.426.3 or 2.442.

## Is CVE-2024-23898 being exploited?

There is no known exploitation of CVE-2024-23898 in the wild and no public exploit code.

Public exploit code:

- A proof of concept cross-site WebSocket hijacking exploit for CVE-2024-23898 — a vulnerability affecting Jenkins versions 2.217-2.441.  For educational use in the Hacking & Offensive Security course at Carnegie Mellon University.  (github_poc): https://github.com/davidmgaviria/CVE2_Jenkins_RCE

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23898 and fix it if it is affected.

What it is: CVE-2024-23898 is a high-severity vulnerability in Jenkins Jenkins, published on 24 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-23898 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; no fix listed
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; no fix listed
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.217; fixed in 2.426.3
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.217; fixed in 2.426.3
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.427; fixed in 2.442
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.427; fixed in 2.442
- jenkins (Bitnami): affected from 2.217.0; fixed in 2.452.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23898/ (Markdown: https://insights.sbomify.com/CVE-2024-23898/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23898
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23898
- OSV: https://osv.dev/vulnerability/CVE-2024-23898

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23898/
Summaries are generated and may contain mistakes; the official description above is the record.
