{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:git-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-23899 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:git-server to 99.101.v720e86326c09 or later.","what":"CVE-2024-23899 is a medium-severity path traversal vulnerability in Jenkins Git server Plugin, published on 24 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-23899 and fix it if it is affected.\n\nWhat it is: CVE-2024-23899 is a medium-severity path traversal vulnerability in Jenkins Git server Plugin, published on 24 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-23899 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:git-server (Maven): affected all versions; fixed in 99.101.v720e86326c09\n- org.jenkins-ci.plugins:git-server (Maven): affected all versions; fixed in 99.101.v720e86326c09\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-23899/ (Markdown: https://insights.sbomify.com/CVE-2024-23899/index.md)","id":"CVE-2024-23899","markdown":"https://insights.sbomify.com/CVE-2024-23899/index.md","name":"CVE-2024-23899","record":{"aliases":["GHSA-vph5-2q33-7r9h"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Git server Plugin","requires_auth":"low_privilege","summary":"Attackers with read permissions can read arbitrary files on the Jenkins controller due to unsafe command parser behavior.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"git_server","vendor":"jenkins"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Jenkins Git server Plugin 99.va_0826a_b_cdfa_d and earlier does not disable a feature of its command parser that replaces an '@' character followed by a file path in an argument with the file's contents, allowing attackers with Overall/Read permission to read content from arbitrary files on the Jenkins controller file system.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Arbitrary file read vulnerability in Git server Plugin can lead to RCE","id":"CVE-2024-23899","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Path traversal vulnerability in Jenkins Matrix Project Plugin","id":"CVE-2024-23900"},"packages":[{"ecosystem":"Maven","fixed":["99.101.v720e86326c09"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:git-server","purl":null,"source":"GHSA-vph5-2q33-7r9h"},{"ecosystem":"Maven","fixed":["99.101.v720e86326c09"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:git-server","purl":"pkg:maven/org.jenkins-ci.plugins/git-server","source":"GHSA-vph5-2q33-7r9h"}],"prev":{"headline":"Cross-site WebSocket hijacking vulnerability in the Jenkins CLI","id":"CVE-2024-23898"},"products":["Jenkins Git server Plugin"],"published":"2024-01-24","related":[{"cvss_score":6.5,"headline":"Jenkins Git server Plugin does not perform a permission check","id":"CVE-2024-34146","kev_date_added":null,"published":"2024-05-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-04","vendors":["Jenkins Project"]},"summary":"Attackers with read permissions can read arbitrary files on the Jenkins controller due to unsafe command parser behavior.","url":"https://insights.sbomify.com/CVE-2024-23899/"}