# CVE-2024-23899: Arbitrary file read vulnerability in Git server Plugin can lead to RCE

> Attackers with read permissions can read arbitrary files on the Jenkins controller due to unsafe command parser behavior.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jan 2024
- **Updated:** 4 Jun 2025
- **Also known as:** GHSA-vph5-2q33-7r9h

## What is CVE-2024-23899?

CVE-2024-23899 is a medium-severity path traversal vulnerability in Jenkins Git server Plugin, published on 24 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Git server Plugin 99.va_0826a_b_cdfa_d and earlier does not disable a feature of its command parser that replaces an '@' character followed by a file path in an argument with the file's contents, allowing attackers with Overall/Read permission to read content from arbitrary files on the Jenkins controller file system.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-23899?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:git-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:git-server` | Maven | All versions | 99.101.v720e86326c09 |
| `org.jenkins-ci.plugins:git-server` | Maven | All versions | 99.101.v720e86326c09 |

Products: Jenkins Git Server.

## How do I fix CVE-2024-23899?

Upgrade org.jenkins-ci.plugins:git-server to 99.101.v720e86326c09 or later.

## Is CVE-2024-23899 being exploited?

There is no known exploitation of CVE-2024-23899 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Git server Plugin

- [CVE-2024-34146](https://insights.sbomify.com/CVE-2024-34146/): Jenkins Git server Plugin does not perform a permission check (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23899 and fix it if it is affected.

What it is: CVE-2024-23899 is a medium-severity path traversal vulnerability in Jenkins Git server Plugin, published on 24 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23899 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:git-server (Maven): affected all versions; fixed in 99.101.v720e86326c09
- org.jenkins-ci.plugins:git-server (Maven): affected all versions; fixed in 99.101.v720e86326c09

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23899/ (Markdown: https://insights.sbomify.com/CVE-2024-23899/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23899
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23899
- OSV: https://osv.dev/vulnerability/CVE-2024-23899

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23899/
Summaries are generated and may contain mistakes; the official description above is the record.
