{"answers":{"affected":"2 open source packages ship an affected version, including io.jenkins.plugins:redhat-dependency-analytics. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-23905 in the wild and no public exploit code.","fix":"Upgrade io.jenkins.plugins:redhat-dependency-analytics to 0.9.0 or later.","what":"CVE-2024-23905 is a medium-severity cross-site scripting vulnerability in Jenkins Red Hat Dependency Analytics Plugin, published on 24 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-23905 and fix it if it is affected.\n\nWhat it is: CVE-2024-23905 is a medium-severity cross-site scripting vulnerability in Jenkins Red Hat Dependency Analytics Plugin, published on 24 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-23905 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.jenkins.plugins:redhat-dependency-analytics (Maven): affected all versions; fixed in 0.9.0\n- io.jenkins.plugins:redhat-dependency-analytics (Maven): affected all versions; fixed in 0.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-23905/ (Markdown: https://insights.sbomify.com/CVE-2024-23905/index.md)","id":"CVE-2024-23905","markdown":"https://insights.sbomify.com/CVE-2024-23905/index.md","name":"CVE-2024-23905","record":{"aliases":["GHSA-x22x-5pp9-8v7f"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary scripts in Jenkins workspaces because the plugin disables Content-Security-Policy protections for user-generated content.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"red_hat_dependency_analytics","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Red Hat Dependency Analytics Plugin 0.7.1 and earlier programmatically disables Content-Security-Policy protection for user-generated content in workspaces, archived artifacts, etc. that Jenkins offers for download.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Content-Security-Policy disabled by Red Hat Dependency Analytics Jenkins Plugin","id":"CVE-2024-23905","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site scripting in Controller 6000 and Controller 7000","id":"CVE-2024-23906"},"packages":[{"ecosystem":"Maven","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:redhat-dependency-analytics","purl":null,"source":"GHSA-x22x-5pp9-8v7f"},{"ecosystem":"Maven","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:redhat-dependency-analytics","purl":"pkg:maven/io.jenkins.plugins/redhat-dependency-analytics","source":"GHSA-x22x-5pp9-8v7f"}],"prev":{"headline":"Arbitrary file read vulnerability in Jenkins Log Command Plugin","id":"CVE-2024-23904"},"products":["Jenkins Red Hat Dependency Analytics Plugin"],"published":"2024-01-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-20","vendors":["Jenkins Project"]},"summary":"Attackers can execute arbitrary scripts in Jenkins workspaces because the plugin disables Content-Security-Policy protections for user-generated content.","url":"https://insights.sbomify.com/CVE-2024-23905/"}