# CVE-2024-23905: Content-Security-Policy disabled by Red Hat Dependency Analytics Jenkins Plugin

> Attackers can execute arbitrary scripts in Jenkins workspaces because the plugin disables Content-Security-Policy protections for user-generated content.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jan 2024
- **Updated:** 20 Jun 2025
- **Also known as:** GHSA-x22x-5pp9-8v7f

## What is CVE-2024-23905?

CVE-2024-23905 is a medium-severity cross-site scripting vulnerability in Jenkins Red Hat Dependency Analytics Plugin, published on 24 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins Red Hat Dependency Analytics Plugin 0.7.1 and earlier programmatically disables Content-Security-Policy protection for user-generated content in workspaces, archived artifacts, etc. that Jenkins offers for download.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-23905?

2 open source packages ship an affected version, including io.jenkins.plugins:redhat-dependency-analytics. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:redhat-dependency-analytics` | Maven | All versions | 0.9.0 |
| `io.jenkins.plugins:redhat-dependency-analytics` | Maven | All versions | 0.9.0 |

Products: Jenkins Red Hat Dependency Analytics.

## How do I fix CVE-2024-23905?

Upgrade io.jenkins.plugins:redhat-dependency-analytics to 0.9.0 or later.

## Is CVE-2024-23905 being exploited?

There is no known exploitation of CVE-2024-23905 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23905 and fix it if it is affected.

What it is: CVE-2024-23905 is a medium-severity cross-site scripting vulnerability in Jenkins Red Hat Dependency Analytics Plugin, published on 24 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-23905 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:redhat-dependency-analytics (Maven): affected all versions; fixed in 0.9.0
- io.jenkins.plugins:redhat-dependency-analytics (Maven): affected all versions; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23905/ (Markdown: https://insights.sbomify.com/CVE-2024-23905/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23905
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23905
- OSV: https://osv.dev/vulnerability/CVE-2024-23905

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23905/
Summaries are generated and may contain mistakes; the official description above is the record.
