# CVE-2024-23944: Apache ZooKeeper: Information disclosure in persistent watcher handling

> Attackers can monitor child znodes and expose sensitive path information via persistent watchers due to missing ACL checks in Apache ZooKeeper.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Mar 2024
- **Updated:** 3 Jul 2025
- **Also known as:** BIT-zookeeper-2024-23944, CLEANSTART-2026-YW96996, DEBIAN-CVE-2024-23944, ECHO-0e1c-8839-7f9b, GHSA-r978-9m6m-6gm6, MINI-48vw-6g2m-74f4, MINI-8qhj-4vcx-x6f6, MINI-wrw4-qx93-q9xx, UBUNTU-CVE-2024-23944

## What is CVE-2024-23944?

CVE-2024-23944 is a medium-severity missing authorization vulnerability in Apache ZooKeeper, published on 15 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Information disclosure in persistent watchers handling in Apache ZooKeeper due to missing ACL check. It allows an attacker to monitor child znodes by attaching a persistent watcher (addWatch command) to a parent which the attacker has already access to. ZooKeeper server doesn't do ACL check when the persistent watcher is triggered and as a consequence, the full path of znodes that a watch event gets triggered upon is exposed to the owner of the watcher. It's important to note that only the path is exposed by this vulnerability, not the data of znode, but since znode path can contain sensitive information like user name or login ID, this issue is potentially critical.

Users are recommended to upgrade to version 3.9.2, 3.8.4 which fixes the issue.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-23944?

7 open source packages ship an affected version, including org.apache.zookeeper:zookeeper and zookeeper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.zookeeper:zookeeper` | Maven | From 3.6.0 to 3.7.2 | None |
| `org.apache.zookeeper:zookeeper` | Maven | From 3.6.0 to 3.7.2 | None |
| `org.apache.zookeeper:zookeeper` | Maven | From 3.8.0 | 3.8.4 |
| `org.apache.zookeeper:zookeeper` | Maven | From 3.8.0 | 3.8.4 |
| `org.apache.zookeeper:zookeeper` | Maven | From 3.9.0 | 3.9.2 |
| `org.apache.zookeeper:zookeeper` | Maven | From 3.9.0 | 3.9.2 |
| `zookeeper` | Bitnami | From 3.6.0 | 3.8.4, 3.9.2 |

Products: Apache Zookeeper.

## How do I fix CVE-2024-23944?

Upgrade org.apache.zookeeper:zookeeper to a fixed version for your release line: 3.8.4 or 3.9.2.

## Is CVE-2024-23944 being exploited?

There is no known exploitation of CVE-2024-23944 in the wild and no public exploit code.

## Other vulnerabilities in Apache ZooKeeper

- [CVE-2024-51504](https://insights.sbomify.com/CVE-2024-51504/): Apache ZooKeeper: Authentication bypass with IP-based authentication in Admin Server (critical 9.1)
- [CVE-2023-44981](https://insights.sbomify.com/CVE-2023-44981/): Apache ZooKeeper: Authorization bypass in SASL Quorum Peer Authentication (critical 9.1)
- [CVE-2016-5017](https://insights.sbomify.com/CVE-2016-5017/): Memory corruption in n/a (high 8.1)
- [CVE-2026-59739](https://insights.sbomify.com/CVE-2026-59739/): Apache ZooKeeper: Information disclosure via SetWatches reconnect replay (high 7.5)
- [CVE-2026-59969](https://insights.sbomify.com/CVE-2026-59969/): Apache ZooKeeper: Improper validation of certificate with host mismatch in FIPS mode (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23944 and fix it if it is affected.

What it is: CVE-2024-23944 is a medium-severity missing authorization vulnerability in Apache ZooKeeper, published on 15 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23944 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.zookeeper:zookeeper (Maven): affected from 3.6.0 up to 3.7.2; no fix listed
- org.apache.zookeeper:zookeeper (Maven): affected from 3.6.0 up to 3.7.2; no fix listed
- org.apache.zookeeper:zookeeper (Maven): affected from 3.8.0; fixed in 3.8.4
- org.apache.zookeeper:zookeeper (Maven): affected from 3.8.0; fixed in 3.8.4
- org.apache.zookeeper:zookeeper (Maven): affected from 3.9.0; fixed in 3.9.2
- org.apache.zookeeper:zookeeper (Maven): affected from 3.9.0; fixed in 3.9.2
- zookeeper (Bitnami): affected from 3.6.0; fixed in 3.8.4, 3.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23944/ (Markdown: https://insights.sbomify.com/CVE-2024-23944/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23944
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23944
- OSV: https://osv.dev/vulnerability/CVE-2024-23944

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23944/
Summaries are generated and may contain mistakes; the official description above is the record.
