# CVE-2024-23953: Apache Hive: Timing Attack Against Signature in LLAP util

> An authorized user can bypass signature validation in Apache Hive LLAP to forge signatures, potentially escalating privileges or causing denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jan 2025
- **Updated:** 14 Mar 2025
- **Also known as:** CLEANSTART-2026-NO09997, CLEANSTART-2026-RT97024, CLEANSTART-2026-SY76687, GHSA-p953-3j66-hg45, MINI-3fmj-m98c-m2ff

## What is CVE-2024-23953?

CVE-2024-23953 is a medium-severity vulnerability in Apache Hive, published on 28 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Use of Arrays.equals() in LlapSignerImpl in Apache Hive to compare message signatures allows attacker to forge a valid signature for an arbitrary message byte by byte. The attacker should be an authorized user of the product to perform this attack. Users are recommended to upgrade to version 4.0.0, which fixes this issue.

The problem occurs when an application doesn’t use a constant-time algorithm for validating a signature. The method Arrays.equals() returns false right away when it sees that one of the input’s bytes are different. It means that the comparison time depends on the contents of the arrays. This little thing may allow an attacker to forge a valid signature for an arbitrary message byte by byte. So it might allow malicious users to submit splits/work with selected signatures to LLAP without running as a privileged user, potentially leading to DDoS attack.

More details in the reference section.

Weakness: CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2024-23953?

2 open source packages ship an affected version, including org.apache.hive:hive-llap-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hive:hive-llap-common` | Maven | All versions | 4.0.0 |
| `org.apache.hive:hive-llap-common` | Maven | All versions | 4.0.0 |

Products: Apache Hive.

## How do I fix CVE-2024-23953?

Upgrade org.apache.hive:hive-llap-common to 4.0.0 or later.

## Is CVE-2024-23953 being exploited?

There is no known exploitation of CVE-2024-23953 in the wild and no public exploit code.

## Other vulnerabilities in Apache Hive

- [CVE-2026-49845](https://insights.sbomify.com/CVE-2026-49845/): Apache Hive: SQL Injection vulnerability in HiveMetaStore partition-name direct-SQL paths (critical 9.8)
- [CVE-2018-21234](https://insights.sbomify.com/CVE-2018-21234/): Deserialization of Untrusted Data in Jodd (critical 9.8)
- [CVE-2026-55976](https://insights.sbomify.com/CVE-2026-55976/): Apache Hive: SSRF vulnerability in Hive Avro Serde due to Insufficient input validation on avro.schema.url (critical 9.1)
- [CVE-2018-1282](https://insights.sbomify.com/CVE-2018-1282/): SQL Injection in hive-jdbc (critical 9.1)
- [CVE-2022-41137](https://insights.sbomify.com/CVE-2022-41137/): Apache Hive: Deserialization of untrusted data when fetching partitions from the Metastore (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23953 and fix it if it is affected.

What it is: CVE-2024-23953 is a medium-severity vulnerability in Apache Hive, published on 28 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23953 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hive:hive-llap-common (Maven): affected all versions; fixed in 4.0.0
- org.apache.hive:hive-llap-common (Maven): affected all versions; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23953/ (Markdown: https://insights.sbomify.com/CVE-2024-23953/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23953
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23953
- OSV: https://osv.dev/vulnerability/CVE-2024-23953

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23953/
Summaries are generated and may contain mistakes; the official description above is the record.
