CVE-2024-2408 PHP is vulnerable to the Marvin Attack

Medium 5.9 Published Updated

PHP is vulnerable to the Marvin Attack via PKCS1 padding, allowing attackers to decrypt data or bypass security checks if using unpatched OpenSSL versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-2408?

CVE-2024-2408 is a medium-severity vulnerability in Fedoraproject Fedora, published on 9 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The openssl_private_decrypt function in PHP, when using PKCS1 padding (OPENSSL_PKCS1_PADDING, which is the default), is vulnerable to the Marvin Attack unless it is used with an OpenSSL version that includes the changes from this pull request: https://github.com/openssl/openssl/pull/13817 (rsa_pkcs1_implicit_rejection). These changes are part of OpenSSL 3.2 and have also been backported to stable versions of various Linux distributions, as well as to the PHP builds provided for Windows since the previous release. All distributors and builders should ensure that this version is used to prevent PHP from being vulnerable.

PHP Windows builds for the versions 8.1.29, 8.2.20 and 8.3.8 and above include OpenSSL patches that fix the vulnerability.

Weakness: CWE-203

Which versions are affected by CVE-2024-2408?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 2 products.

PackageAffectedFixed in
libphp BitnamiAll versions8.1.29, 8.2.20, 8.3.8
php BitnamiAll versions8.1.29, 8.2.20, 8.3.8
php-min BitnamiAll versions8.1.29, 8.2.20, 8.3.8

Products include Fedoraproject Fedora, Php Php.

How do I fix CVE-2024-2408?

Upgrade libphp to a fixed version for your release line: 8.1.29, 8.2.20 or 8.3.8.

Is CVE-2024-2408 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2408 exists.

All Fedoraproject Fedora vulnerabilities

Sources

Also known as AZL-42616, AZL-42628, BIT-libphp-2024-2408, BIT-php-2024-2408, BIT-php-min-2024-2408, CLSA-2025-1742661821 and 3 more.

Is CVE-2024-2408 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free