{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2408 exists.","fix":"Upgrade libphp to a fixed version for your release line: 8.1.29, 8.2.20 or 8.3.8.","what":"CVE-2024-2408 is a medium-severity vulnerability in Fedoraproject Fedora, published on 9 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-2408 and fix it if it is affected.\n\nWhat it is: CVE-2024-2408 is a medium-severity vulnerability in Fedoraproject Fedora, published on 9 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2408 exists.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected all versions; fixed in 8.1.29, 8.2.20, 8.3.8\n- php (Bitnami): affected all versions; fixed in 8.1.29, 8.2.20, 8.3.8\n- php-min (Bitnami): affected all versions; fixed in 8.1.29, 8.2.20, 8.3.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-2408/ (Markdown: https://insights.sbomify.com/CVE-2024-2408/index.md)","id":"CVE-2024-2408","markdown":"https://insights.sbomify.com/CVE-2024-2408/index.md","name":"CVE-2024-2408","record":{"aliases":["AZL-42616","AZL-42628","BIT-libphp-2024-2408","BIT-php-2024-2408","BIT-php-min-2024-2408","CLSA-2025-1742661821","CLSA-2025-1742723010","DEBIAN-CVE-2024-2408","GHSA-hh26-4ppw-5864"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP scripting language","requires_auth":"none","summary":"PHP is vulnerable to the Marvin Attack via PKCS1 padding, allowing attackers to decrypt data or bypass security checks if using unpatched OpenSSL versions.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"php","vendor":"php"}],"cvss":{"score":5.9,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-203","name":"Observable Discrepancy"}],"description":"The openssl_private_decrypt function in PHP, when using PKCS1 padding (OPENSSL_PKCS1_PADDING, which is the default), is vulnerable to the Marvin Attack unless it is used with an OpenSSL version that includes the changes from this pull request:  https://github.com/openssl/openssl/pull/13817  (rsa_pkcs1_implicit_rejection). These changes are part of OpenSSL 3.2 and have also been backported to stable versions of various Linux distributions, as well as to the PHP builds provided for Windows since the previous release. All distributors and builders should ensure that this version is used to prevent PHP from being vulnerable.\n\nPHP Windows builds for the versions 8.1.29, 8.2.20 and 8.3.8 and above include OpenSSL patches that fix the vulnerability.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"PHP is vulnerable to the Marvin Attack","id":"CVE-2024-2408","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"fedoraproject:fedora","products":["fedoraproject:fedora","php:php"],"type":"weak_cryptography","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"MasterStudy LMS \u003c= 3.3.1 - Unauthenticated Privilege Escalation via stm_lms_register AJAX Action","id":"CVE-2024-2409"},"packages":[{"ecosystem":"Bitnami","fixed":["8.1.29","8.2.20","8.3.8"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2024-2408"},{"ecosystem":"Bitnami","fixed":["8.1.29","8.2.20","8.3.8"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2024-2408"},{"ecosystem":"Bitnami","fixed":["8.1.29","8.2.20","8.3.8"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2024-2408"}],"prev":{"headline":"Gacjie Server Upload.php index unrestricted upload","id":"CVE-2024-2406"},"products":["PHP"],"published":"2024-06-09","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-21","vendors":["PHP Group"]},"summary":"PHP is vulnerable to the Marvin Attack via PKCS1 padding, allowing attackers to decrypt data or bypass security checks if using unpatched OpenSSL versions.","url":"https://insights.sbomify.com/CVE-2024-2408/"}