# CVE-2024-2408: PHP is vulnerable to the Marvin Attack

> PHP is vulnerable to the Marvin Attack via PKCS1 padding, allowing attackers to decrypt data or bypass security checks if using unpatched OpenSSL versions.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2024
- **Updated:** 21 Mar 2025
- **Also known as:** AZL-42616, AZL-42628, BIT-libphp-2024-2408, BIT-php-2024-2408, BIT-php-min-2024-2408, CLSA-2025-1742661821, CLSA-2025-1742723010, DEBIAN-CVE-2024-2408, GHSA-hh26-4ppw-5864

## What is CVE-2024-2408?

CVE-2024-2408 is a medium-severity vulnerability in Fedoraproject Fedora, published on 9 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The openssl_private_decrypt function in PHP, when using PKCS1 padding (OPENSSL_PKCS1_PADDING, which is the default), is vulnerable to the Marvin Attack unless it is used with an OpenSSL version that includes the changes from this pull request:  https://github.com/openssl/openssl/pull/13817  (rsa_pkcs1_implicit_rejection). These changes are part of OpenSSL 3.2 and have also been backported to stable versions of various Linux distributions, as well as to the PHP builds provided for Windows since the previous release. All distributors and builders should ensure that this version is used to prevent PHP from being vulnerable.

PHP Windows builds for the versions 8.1.29, 8.2.20 and 8.3.8 and above include OpenSSL patches that fix the vulnerability.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2024-2408?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | All versions | 8.1.29, 8.2.20, 8.3.8 |
| `php` | Bitnami | All versions | 8.1.29, 8.2.20, 8.3.8 |
| `php-min` | Bitnami | All versions | 8.1.29, 8.2.20, 8.3.8 |

Products: Fedoraproject Fedora, Php Php.

## How do I fix CVE-2024-2408?

Upgrade libphp to a fixed version for your release line: 8.1.29, 8.2.20 or 8.3.8.

## Is CVE-2024-2408 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2408 exists.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-2408 and fix it if it is affected.

What it is: CVE-2024-2408 is a medium-severity vulnerability in Fedoraproject Fedora, published on 9 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2408 exists.

Affected packages and fixed versions:
- libphp (Bitnami): affected all versions; fixed in 8.1.29, 8.2.20, 8.3.8
- php (Bitnami): affected all versions; fixed in 8.1.29, 8.2.20, 8.3.8
- php-min (Bitnami): affected all versions; fixed in 8.1.29, 8.2.20, 8.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-2408/ (Markdown: https://insights.sbomify.com/CVE-2024-2408/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-2408
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-2408
- OSV: https://osv.dev/vulnerability/CVE-2024-2408

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-2408/
Summaries are generated and may contain mistakes; the official description above is the record.
