{"answers":{"affected":"1 open source package ship an affected version, including postgresql. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-24213 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-24213 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-24213 is a critical SQL injection vulnerability in n/a, published on 8 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-24213 and fix it if it is affected.\n\nWhat it is: CVE-2024-24213 is a critical SQL injection vulnerability in n/a, published on 8 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-24213 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgresql (Bitnami): affected from 15.1.0 up to 15.1.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-24213/ (Markdown: https://insights.sbomify.com/CVE-2024-24213/index.md)","id":"CVE-2024-24213","markdown":"https://insights.sbomify.com/CVE-2024-24213/index.md","name":"CVE-2024-24213","record":{"aliases":["BIT-postgresql-2024-24213","GHSA-vq84-wx4w-6r76"],"analysis":{"component_type":"database","fix_type":"no_fix_stated","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Supabase PostgreSQL","requires_auth":"none","summary":"A SQL injection vulnerability in Supabase PostgreSQL allows authorized users to execute arbitrary queries via the dashboard, though the vendor considers this an intended feature.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"postgres","vendor":"supabase"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Supabase PostgreSQL v15.1 was discovered to contain a SQL injection vulnerability via the component /pg_meta/default/query. NOTE: the vendor's position is that this is an intended feature; also, it exists in the Supabase dashboard product, not the Supabase PostgreSQL product. Specifically, /pg_meta/default/query is for SQL queries that are entered in an intended UI by an authorized user. Nothing is injected.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"SQL injection in n/a","id":"CVE-2024-24213","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"sql_injection","year":"2024"},"n_packages":1,"n_references":5,"next":{"headline":"Information disclosure in n/a","id":"CVE-2024-24215"},"packages":[{"ecosystem":"Bitnami","fixed":[],"introduced":["15.1.0"],"last_affected":["15.1.0"],"package":"postgresql","purl":"pkg:bitnami/postgresql","source":"BIT-postgresql-2024-24213"}],"prev":{"headline":"File upload in n/a","id":"CVE-2024-24202"},"products":["n/a"],"published":"2024-02-08","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-19","vendors":["n/a"]},"summary":"A SQL injection vulnerability in Supabase PostgreSQL allows authorized users to execute arbitrary queries via the dashboard, though the vendor considers this an intended feature.","url":"https://insights.sbomify.com/CVE-2024-24213/"}