# CVE-2024-24294: Blackprint @blackprint/engine Prototype Pollution issue

> An attacker can execute arbitrary code via prototype pollution in the Blackprint engine library, requiring an upgrade to mitigate.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 May 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-g3q2-vcjq-rgrc

## What is CVE-2024-24294?

CVE-2024-24294 is a critical code injection vulnerability in n/a, published on 20 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Prototype Pollution issue in Blackprint @blackprint/engine v.0.9.0 allows an attacker to execute arbitrary code via the _utils.setDeepProperty function of engine.min.js.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-24294?

2 open source packages ship an affected version, including @blackprint/engine.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@blackprint/engine` | npm | From 0.8.12 | 0.9.2 |
| `@blackprint/engine` | npm | From 0.8.12 | 0.9.2 |

## How do I fix CVE-2024-24294?

Upgrade @blackprint/engine to 0.9.2 or later.

## Is CVE-2024-24294 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-24294 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24294 and fix it if it is affected.

What it is: CVE-2024-24294 is a critical code injection vulnerability in n/a, published on 20 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-24294 exists.

Affected packages and fixed versions:
- @blackprint/engine (npm): affected from 0.8.12; fixed in 0.9.2
- @blackprint/engine (npm): affected from 0.8.12; fixed in 0.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24294/ (Markdown: https://insights.sbomify.com/CVE-2024-24294/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24294
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24294
- OSV: https://osv.dev/vulnerability/CVE-2024-24294

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24294/
Summaries are generated and may contain mistakes; the official description above is the record.
