CVE-2024-2434 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab

High 8.5 Published Updated

Attackers can exploit path traversal in GitLab to read restricted files and cause denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-2434?

CVE-2024-2434 is a high-severity path traversal vulnerability in Gitlab Gitlab, published on 25 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab affecting all versions of GitLab CE/EE 16.9 prior to 16.9.6, 16.10 prior to 16.10.4, and 16.11 prior to 16.11.1 where path traversal could lead to DoS and restricted file read.

Weakness: CWE-22

Which versions are affected by CVE-2024-2434?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.9.016.9.6, 16.10.4, 16.11.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-2434?

Upgrade gitlab to a fixed version for your release line: 16.9.6, 16.10.4 or 16.11.1.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2024-2434 being exploited?

There is no known exploitation of CVE-2024-2434 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-2434, GHSA-gwr5-7mcm-726j, UBUNTU-CVE-2024-2434.

Is CVE-2024-2434 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free