# CVE-2024-2435: Stored XSS in Timeline View

> An attacker with signal-sending permissions can inject scripts into workflow signal names, leading to stored XSS when victims view the timeline.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Apr 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-8f25-w7qj-r7hc, GO-2024-2675

## What is CVE-2024-2435?

CVE-2024-2435 is a medium-severity cross-site scripting vulnerability in Temporal OSS ui-server, published on 2 Apr 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

For an attacker with pre-existing access to send a signal to a workflow, the attacker can make the signal name a script that executes when a victim views that signal. The XSS is in the timeline page displaying the workflow execution details of the workflow that was sent the crafted signal.
Access to send a signal to a workflow is determined by how you configured the authorizer on your server. This includes any entity with permission to directly call SignalWorkflowExecution or SignalWithStartWorkflowExecution, or any entity can deploy a worker that has access to call workflow progress APIs (specifically RespondWorkflowTaskCompleted).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-2435?

4 open source packages ship an affected version, including github.com/temporalio/ui-server/v2 and github.com/temporalio/ui-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/temporalio/ui-server/v2` | Go | All versions | 2.25.0 |
| `github.com/temporalio/ui-server/v2` | Go | All versions | 2.25.0 |
| `github.com/temporalio/ui-server/v2` | Go | All versions | 2.25.0 |
| `github.com/temporalio/ui-server` | Go | All versions | None |

## How do I fix CVE-2024-2435?

Upgrade github.com/temporalio/ui-server/v2 to 2.25.0 or later.

## Is CVE-2024-2435 being exploited?

There is no known exploitation of CVE-2024-2435 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-2435 and fix it if it is affected.

What it is: CVE-2024-2435 is a medium-severity cross-site scripting vulnerability in Temporal OSS ui-server, published on 2 Apr 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-2435 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/temporalio/ui-server/v2 (Go): affected all versions; fixed in 2.25.0
- github.com/temporalio/ui-server/v2 (Go): affected all versions; fixed in 2.25.0
- github.com/temporalio/ui-server/v2 (Go): affected all versions; fixed in 2.25.0
- github.com/temporalio/ui-server (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-2435/ (Markdown: https://insights.sbomify.com/CVE-2024-2435/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-2435
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-2435
- OSV: https://osv.dev/vulnerability/CVE-2024-2435

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-2435/
Summaries are generated and may contain mistakes; the official description above is the record.
