CVE-2024-24416 Memory corruption in n/a
Attackers can cause a Denial of Service in Magma 5G core by sending crafted NAS packets that trigger a buffer overflow.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-24416?
CVE-2024-24416 is a high-severity memory corruption vulnerability in n/a, published on 21 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Linux Foundation Magma <= 1.8.0 (fixed in v1.9 commit 08472ba98b8321f802e95f5622fa90fec2dea486) was discovered to contain a buffer overflow in the decode_access_point_name_ie function at /3gpp/3gpp_24.008_sm_ies.c. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted NAS packet.
Weakness: CWE-120
Which versions are affected by CVE-2024-24416?
It affects 1 product.
Products include Linuxfoundation Magma.
How do I fix CVE-2024-24416?
No fix has been published for CVE-2024-24416 yet. Limit exposure of the affected software until one is available.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2024-24416 being exploited?
There is no known exploitation of CVE-2024-24416 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-8x7c-w8p2-82h5.