CVE-2024-24418 Memory corruption in n/a

High 7.5 Published Updated

Attackers can cause a Denial of Service in Magma by sending crafted NAS packets that trigger a buffer overflow.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-24418?

CVE-2024-24418 is a high-severity memory corruption vulnerability in n/a, published on 21 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Linux Foundation Magma <= 1.8.0 (fixed in v1.9 commit 08472ba98b8321f802e95f5622fa90fec2dea486) was discovered to contain a buffer overflow in the decode_pdn_address function at /nas/ies/PdnAddress.cpp. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted NAS packet.

Weakness: CWE-120

Which versions are affected by CVE-2024-24418?

It affects 1 product.

Products include Linuxfoundation Magma.

How do I fix CVE-2024-24418?

No fix has been published for CVE-2024-24418 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2024-24418 being exploited?

There is no known exploitation of CVE-2024-24418 in the wild and no public exploit code.

Sources

Also known as GHSA-hgmm-hq8f-f7pc.

Is CVE-2024-24418 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free