# CVE-2024-24422: Memory corruption in n/a

> Attackers can cause a Denial of Service in Magma 5G core by sending crafted NAS packets that trigger a stack overflow.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 21 Jan 2025
- **Updated:** 19 Mar 2025
- **Also known as:** GHSA-3mqp-g9h4-rcqw

## What is CVE-2024-24422?

CVE-2024-24422 is a high-severity memory corruption vulnerability in n/a, published on 21 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Linux Foundation Magma <= 1.8.0 (fixed in v1.9 commit 08472ba98b8321f802e95f5622fa90fec2dea486) was discovered to contain a stack overflow in the decode_protocol_configuration_options function at /3gpp/3gpp_24.008_sm_ies.c. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted NAS packet.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2024-24422?

It affects 1 product.


Products: Linuxfoundation Magma.

## How do I fix CVE-2024-24422?

No fix has been published for CVE-2024-24422 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-24422 being exploited?

There is no known exploitation of CVE-2024-24422 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-24421](https://insights.sbomify.com/CVE-2024-24421/): Code injection in n/a (critical 9.8)
- [CVE-2023-37024](https://insights.sbomify.com/CVE-2023-37024/): Denial of service in n/a (high 7.5)
- [CVE-2023-37029](https://insights.sbomify.com/CVE-2023-37029/): Denial of service in n/a (high 7.5)
- [CVE-2023-37032](https://insights.sbomify.com/CVE-2023-37032/): Memory corruption in n/a (high 7.5)
- [CVE-2024-24416](https://insights.sbomify.com/CVE-2024-24416/): Memory corruption in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24422 and fix it if it is affected.

What it is: CVE-2024-24422 is a high-severity memory corruption vulnerability in n/a, published on 21 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-24422 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24422/ (Markdown: https://insights.sbomify.com/CVE-2024-24422/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24422
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24422
- OSV: https://osv.dev/vulnerability/CVE-2024-24422

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24422/
Summaries are generated and may contain mistakes; the official description above is the record.
