CVE-2024-2445 Reflected XSS in Mattermost Jira plugin

Medium 6.1 Published Updated

Attackers can execute arbitrary scripts in users' browsers via reflected XSS in the Mattermost Jira plugin, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-2445?

CVE-2024-2445 is a medium-severity cross-site scripting vulnerability in Mattermost Mattermost Server, published on 15 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Mattermost Jira plugin versions shipped with Mattermost versions 8.1.x before 8.1.10, 9.2.x before 9.2.6, 9.3.x before 9.3.2, and 9.4.x before 9.4.3 fail to escape user-controlled outputs when generating HTML pages, which allows an attacker to perform reflected cross-site scripting attacks against the users of the Mattermost server.

Weakness: CWE-79, CWE-74

Which versions are affected by CVE-2024-2445?

1 open source package ship an affected version, including mattermost. It affects 1 product.

PackageAffectedFixed in
mattermost BitnamiFrom 8.1.08.1.10, 9.2.6, 9.3.2, 9.4.3

Products include Mattermost Mattermost Server.

How do I fix CVE-2024-2445?

Upgrade mattermost to a fixed version for your release line: 8.1.10, 9.2.6, 9.3.2 or 9.4.3.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-2445 being exploited?

There is no known exploitation of CVE-2024-2445 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as BIT-mattermost-2024-2445, GHSA-m6gm-m2m7-vwxg.

Is CVE-2024-2445 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free