{"answers":{"affected":"1 open source package ship an affected version, including mattermost. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-2445 in the wild and no public exploit code.","fix":"Upgrade mattermost to a fixed version for your release line: 8.1.10, 9.2.6, 9.3.2 or 9.4.3.","what":"CVE-2024-2445 is a medium-severity cross-site scripting vulnerability in Mattermost Mattermost Server, published on 15 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-2445 and fix it if it is affected.\n\nWhat it is: CVE-2024-2445 is a medium-severity cross-site scripting vulnerability in Mattermost Mattermost Server, published on 15 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-2445 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mattermost (Bitnami): affected from 8.1.0; fixed in 8.1.10, 9.2.6, 9.3.2, 9.4.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-2445/ (Markdown: https://insights.sbomify.com/CVE-2024-2445/index.md)","id":"CVE-2024-2445","markdown":"https://insights.sbomify.com/CVE-2024-2445/index.md","name":"CVE-2024-2445","record":{"aliases":["BIT-mattermost-2024-2445","GHSA-m6gm-m2m7-vwxg"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Mattermost Jira plugin","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in users' browsers via reflected XSS in the Mattermost Jira plugin, potentially leading to account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mattermost","cpe":[{"product":"mattermost_server","vendor":"mattermost"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"Mattermost Jira plugin versions shipped with Mattermost versions 8.1.x before 8.1.10, 9.2.x before 9.2.6, 9.3.x before 9.3.2, and 9.4.x before 9.4.3 fail to escape user-controlled outputs when generating HTML pages, which allows an attacker to perform reflected cross-site scripting attacks against the users of the Mattermost server.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Reflected XSS in Mattermost Jira plugin","id":"CVE-2024-2445","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"mattermost:mattermost_server","products":["mattermost:mattermost_server"],"type":"xss","year":"2024"},"n_packages":1,"n_references":1,"next":{"headline":"Denial of service in Mattermost","id":"CVE-2024-2446"},"packages":[{"ecosystem":"Bitnami","fixed":["8.1.10","9.2.6","9.3.2","9.4.3"],"introduced":["8.1.0","9.2.0","9.3.0","9.4.0"],"last_affected":[],"package":"mattermost","purl":"pkg:bitnami/mattermost","source":"BIT-mattermost-2024-2445"}],"prev":{"headline":"Inline Related Posts \u003c 3.5.0 - Admin+ Stored XSS","id":"CVE-2024-2444"},"products":["Mattermost"],"published":"2024-03-15","related":[{"cvss_score":9.9,"headline":"Account takeover on OAuth/OpenID-enabled servers","id":"CVE-2025-12419","kev_date_added":null,"published":"2025-11-27"},{"cvss_score":9.9,"headline":"Account Takeover via Code Exchange Endpoint","id":"CVE-2025-12421","kev_date_added":null,"published":"2025-11-27"},{"cvss_score":9.9,"headline":"Path Traversal Leading to RCE by Any Authenticated Mattermost User","id":"CVE-2025-4981","kev_date_added":null,"published":"2025-06-20"},{"cvss_score":9.9,"headline":"Arbitrary file read via block duplication in Mattermost Boards","id":"CVE-2025-20051","kev_date_added":null,"published":"2025-02-24"},{"cvss_score":9.9,"headline":"Arbitrary file read in Mattermost Boards via import \u0026 export board archive","id":"CVE-2025-25279","kev_date_added":null,"published":"2025-02-24"},{"cvss_score":9.8,"headline":"Mattermost Server: Insufficient Password-Reset Link Invalidation","id":"CVE-2016-11074","kev_date_added":null,"published":"2020-06-19"},{"cvss_score":9.8,"headline":"Mattermost Server allows attackers to gain privileges by accessing unintended API endpoints with users' credentials","id":"CVE-2017-18885","kev_date_added":null,"published":"2020-06-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["Mattermost"]},"summary":"Attackers can execute arbitrary scripts in users' browsers via reflected XSS in the Mattermost Jira plugin, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2024-2445/"}