# CVE-2024-2445: Reflected XSS in Mattermost Jira plugin

> Attackers can execute arbitrary scripts in users' browsers via reflected XSS in the Mattermost Jira plugin, potentially leading to account takeover.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Mar 2024
- **Updated:** 1 Aug 2024
- **Also known as:** BIT-mattermost-2024-2445, GHSA-m6gm-m2m7-vwxg

## What is CVE-2024-2445?

CVE-2024-2445 is a medium-severity cross-site scripting vulnerability in Mattermost Mattermost Server, published on 15 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Mattermost Jira plugin versions shipped with Mattermost versions 8.1.x before 8.1.10, 9.2.x before 9.2.6, 9.3.x before 9.3.2, and 9.4.x before 9.4.3 fail to escape user-controlled outputs when generating HTML pages, which allows an attacker to perform reflected cross-site scripting attacks against the users of the Mattermost server.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2024-2445?

1 open source package ship an affected version, including mattermost. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mattermost` | Bitnami | From 8.1.0 | 8.1.10, 9.2.6, 9.3.2, 9.4.3 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2024-2445?

Upgrade mattermost to a fixed version for your release line: 8.1.10, 9.2.6, 9.3.2 or 9.4.3.

## Is CVE-2024-2445 being exploited?

There is no known exploitation of CVE-2024-2445 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-2445 and fix it if it is affected.

What it is: CVE-2024-2445 is a medium-severity cross-site scripting vulnerability in Mattermost Mattermost Server, published on 15 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-2445 in the wild and no public exploit code.

Affected packages and fixed versions:
- mattermost (Bitnami): affected from 8.1.0; fixed in 8.1.10, 9.2.6, 9.3.2, 9.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-2445/ (Markdown: https://insights.sbomify.com/CVE-2024-2445/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-2445
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-2445
- OSV: https://osv.dev/vulnerability/CVE-2024-2445

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-2445/
Summaries are generated and may contain mistakes; the official description above is the record.
