CVE-2024-2446 Denial of service in Mattermost

Medium 4.3 Published Updated

An authenticated attacker can crash other users' client applications by sending messages with excessive @-mentions, requiring an upgrade to Mattermost.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-2446?

CVE-2024-2446 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 15 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 8.1.x before 8.1.10, 9.2.x before 9.2.6, 9.3.x before 9.3.2, and 9.4.x before 9.4.3 fail to limit the number of @-mentions processed per message, allowing an authenticated attacker to crash the client applications of other users via large, crafted messages.

Weakness: CWE-770, CWE-400

Which versions are affected by CVE-2024-2446?

1 open source package ship an affected version, including mattermost. It affects 1 product.

PackageAffectedFixed in
mattermost BitnamiFrom 8.1.08.1.10, 9.2.6, 9.3.2, 9.4.3

Products include Mattermost Mattermost Server.

How do I fix CVE-2024-2446?

Upgrade mattermost to a fixed version for your release line: 8.1.10, 9.2.6, 9.3.2 or 9.4.3.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-2446 being exploited?

There is no known exploitation of CVE-2024-2446 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as BIT-mattermost-2024-2446, GHSA-x6jw-w885-qwpc.

Is CVE-2024-2446 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free