CVE-2024-2447 Mattermost fails to authenticate the source of certain types of post actions

Medium 6.5 Published Updated

An authenticated attacker can create posts as other users by exploiting missing source authentication in post actions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-2447?

CVE-2024-2447 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 5 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 8.1.x before 8.1.11, 9.3.x before 9.3.3, 9.4.x before 9.4.4, and 9.5.x before 9.5.2 fail to authenticate the source of certain types of post actions, allowing an authenticated attacker to create posts as other users via a crafted post action.

Weakness: CWE-346, CWE-284

Which versions are affected by CVE-2024-2447?

13 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, mattermost and github.com/mattermost/mattermost-server. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versionsNone
github.com/mattermost/mattermost/server/v8 GoFrom 8.1.08.1.11
github.com/mattermost/mattermost/server/v8 GoFrom 8.1.08.1.11
github.com/mattermost/mattermost/server/v8 GoFrom 9.3.09.3.3
github.com/mattermost/mattermost/server/v8 GoFrom 9.3.09.3.3
github.com/mattermost/mattermost/server/v8 GoFrom 9.4.09.4.4
7 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 9.4.09.4.4
github.com/mattermost/mattermost/server/v8 GoFrom 9.5.09.5.2
github.com/mattermost/mattermost/server/v8 GoFrom 9.5.09.5.2
mattermost BitnamiFrom 8.1.08.1.11, 9.3.3, 9.4.4, 9.5.2
github.com/mattermost/mattermost-server GoFrom 9.3.0+incompatible9.3.3+incompatible, 9.4.4+incompatible, 9.5.2+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost Server.

How do I fix CVE-2024-2447?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.1.11, 9.3.3, 9.4.4 or 9.5.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-2447 being exploited?

There is no known exploitation of CVE-2024-2447 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as BIT-mattermost-2024-2447, GHSA-wp43-vprh-c3w5, GO-2024-2696.

Is CVE-2024-2447 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free