CVE-2024-2450 Auth bypass in Mattermost

High 8.8 Published Updated

Authenticated attackers can take over other user accounts by exploiting improper ownership verification during email-to-SAML authentication switches.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-2450?

CVE-2024-2450 is a high-severity authentication bypass vulnerability in Mattermost Mattermost Server, published on 15 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 8.1.x before 8.1.10, 9.2.x before 9.2.6, 9.3.x before 9.3.2, and 9.4.x before 9.4.3 fail to correctly verify account ownership when switching from email to SAML authentication, allowing an authenticated attacker to take over other user accounts via a crafted switch request under specific conditions.

Weakness: CWE-306, CWE-287

Which versions are affected by CVE-2024-2450?

1 open source package ship an affected version, including mattermost. It affects 1 product.

PackageAffectedFixed in
mattermost BitnamiFrom 8.1.0 to 9.5.08.1.10, 9.2.6, 9.3.2, 9.4.3

Products include Mattermost Mattermost Server.

How do I fix CVE-2024-2450?

Upgrade mattermost to a fixed version for your release line: 8.1.10, 9.2.6, 9.3.2 or 9.4.3.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2024-2450 being exploited?

There is no known exploitation of CVE-2024-2450 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as BIT-mattermost-2024-2450, GHSA-33qh-fj99-2gvg.

Is CVE-2024-2450 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free