# CVE-2024-2450: Auth bypass in Mattermost

> Authenticated attackers can take over other user accounts by exploiting improper ownership verification during email-to-SAML authentication switches.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-mattermost-2024-2450, GHSA-33qh-fj99-2gvg

## What is CVE-2024-2450?

CVE-2024-2450 is a high-severity authentication bypass vulnerability in Mattermost Mattermost Server, published on 15 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 8.1.x before 8.1.10, 9.2.x before 9.2.6, 9.3.x before 9.3.2, and 9.4.x before 9.4.3 fail to correctly verify account ownership when switching from email to SAML authentication, allowing an authenticated attacker to take over other user accounts via a crafted switch request under specific conditions.

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2024-2450?

1 open source package ship an affected version, including mattermost. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mattermost` | Bitnami | From 8.1.0 to 9.5.0 | 8.1.10, 9.2.6, 9.3.2, 9.4.3 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2024-2450?

Upgrade mattermost to a fixed version for your release line: 8.1.10, 9.2.6, 9.3.2 or 9.4.3.

## Is CVE-2024-2450 being exploited?

There is no known exploitation of CVE-2024-2450 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-2450 and fix it if it is affected.

What it is: CVE-2024-2450 is a high-severity authentication bypass vulnerability in Mattermost Mattermost Server, published on 15 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-2450 in the wild and no public exploit code.

Affected packages and fixed versions:
- mattermost (Bitnami): affected from 8.1.0 up to 9.5.0; fixed in 8.1.10, 9.2.6, 9.3.2, 9.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-2450/ (Markdown: https://insights.sbomify.com/CVE-2024-2450/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-2450
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-2450
- OSV: https://osv.dev/vulnerability/CVE-2024-2450

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-2450/
Summaries are generated and may contain mistakes; the official description above is the record.
