CVE-2024-2454 Allocation of Resources Without Limits or Throttling in GitLab
Attackers can cause denial of service in GitLab via crafted requests to the pins endpoint, requiring immediate upgrade.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-2454?
CVE-2024-2454 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 9 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 15.11 prior to 16.9.7, starting from 16.10 prior to 16.10.5, and starting from 16.11 prior to 16.11.2. The pins endpoint is susceptible to DoS through a crafted request.
Weakness: CWE-770
Which versions are affected by CVE-2024-2454?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 15.11.0 | 16.9.7, 16.10.5, 16.11.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-2454?
Upgrade gitlab to a fixed version for your release line: 16.9.7, 16.10.5 or 16.11.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-2454 being exploited?
There is no known exploitation of CVE-2024-2454 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-2454, GHSA-6mjw-gpqr-2788, UBUNTU-CVE-2024-2454.