CVE-2024-24549 Apache Tomcat: HTTP/2 header handling DoS
Attackers can cause denial of service in Apache Tomcat by sending HTTP/2 requests with excessive headers, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-24549?
CVE-2024-24549 is a high-severity denial of service vulnerability in Apache Tomcat, published on 13 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Other, older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.
Weakness: CWE-20
Which versions are affected by CVE-2024-24549?
17 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-coyote. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.19 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.19 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.0-M17 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.0-M17 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 | 8.5.99 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 | 8.5.99 |
11 more packages
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0-M1 | 9.0.86 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.0-M1 | 9.0.86 |
tomcat Bitnami | From 8.5.0 | 8.5.99, 9.0.86, 10.1.19 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.0-M1 | 10.1.19 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.0-M1 | 10.1.19 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.0-M1 | 11.0.0-M17 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.0-M1 | 11.0.0-M17 |
org.apache.tomcat:tomcat-coyote Maven | From 8.5.0 | 8.5.99 |
org.apache.tomcat:tomcat-coyote Maven | From 8.5.0 | 8.5.99 |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.0-M1 | 9.0.86 |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.0-M1 | 9.0.86 |
Products include Apache Tomcat, Debian Debian Linux, Fedoraproject Fedora.
How do I fix CVE-2024-24549?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.19, 11.0.0-M17, 8.5.99 or 9.0.86.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-24549 being exploited?
There is no known exploitation of CVE-2024-24549 in the wild and no public exploit code.
Public exploit code: 2 proofs of concept on GitHub.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2024-24549, CLSA-2025-1740051873, DEBIAN-CVE-2024-24549, GHSA-7w75-32cg-r6g2, ROOT-APP-MAVEN-CVE-2024-24549, UBUNTU-CVE-2024-24549.