# CVE-2024-24549: Apache Tomcat: HTTP/2 header handling DoS

> Attackers can cause denial of service in Apache Tomcat by sending HTTP/2 requests with excessive headers, requiring an upgrade to patched versions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2024
- **Updated:** 29 Oct 2025
- **Also known as:** BIT-tomcat-2024-24549, CLSA-2025-1740051873, DEBIAN-CVE-2024-24549, GHSA-7w75-32cg-r6g2, ROOT-APP-MAVEN-CVE-2024-24549, UBUNTU-CVE-2024-24549

## What is CVE-2024-24549?

CVE-2024-24549 is a high-severity denial of service vulnerability in Apache Tomcat, published on 13 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Other, older, EOL versions may also be affected.

Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-24549?

17 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-coyote. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.0-M1 | 10.1.19 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.0-M1 | 10.1.19 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M1 | 11.0.0-M17 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M1 | 11.0.0-M17 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 8.5.0 | 8.5.99 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 8.5.0 | 8.5.99 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.0-M1 | 9.0.86 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.0-M1 | 9.0.86 |
| `tomcat` | Bitnami | From 8.5.0 | 8.5.99, 9.0.86, 10.1.19 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 10.1.0-M1 | 10.1.19 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 10.1.0-M1 | 10.1.19 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 11.0.0-M1 | 11.0.0-M17 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 11.0.0-M1 | 11.0.0-M17 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 8.5.0 | 8.5.99 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 8.5.0 | 8.5.99 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 9.0.0-M1 | 9.0.86 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 9.0.0-M1 | 9.0.86 |

Products: Apache Tomcat, Debian Debian Linux, Fedoraproject Fedora.

## How do I fix CVE-2024-24549?

Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.19, 11.0.0-M17, 8.5.99 or 9.0.86.

## Is CVE-2024-24549 being exploited?

There is no known exploitation of CVE-2024-24549 in the wild and no public exploit code.

Public exploit code:

- https://github.com/Abdurahmon3236/CVE-2024-24549 (github_poc): https://github.com/Abdurahmon3236/CVE-2024-24549
- Proof of concept of the CVE-2024-24549, Exploit in Python.  (github_poc): https://github.com/JFOZ1010/CVE-2024-24549

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24549 and fix it if it is affected.

What it is: CVE-2024-24549 is a high-severity denial of service vulnerability in Apache Tomcat, published on 13 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-24549 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.0-M1; fixed in 10.1.19
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.0-M1; fixed in 10.1.19
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M1; fixed in 11.0.0-M17
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M1; fixed in 11.0.0-M17
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 8.5.0; fixed in 8.5.99
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 8.5.0; fixed in 8.5.99
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.0-M1; fixed in 9.0.86
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.0-M1; fixed in 9.0.86
- tomcat (Bitnami): affected from 8.5.0; fixed in 8.5.99, 9.0.86, 10.1.19
- org.apache.tomcat:tomcat-coyote (Maven): affected from 10.1.0-M1; fixed in 10.1.19
- org.apache.tomcat:tomcat-coyote (Maven): affected from 10.1.0-M1; fixed in 10.1.19
- org.apache.tomcat:tomcat-coyote (Maven): affected from 11.0.0-M1; fixed in 11.0.0-M17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24549/ (Markdown: https://insights.sbomify.com/CVE-2024-24549/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24549
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24549
- OSV: https://osv.dev/vulnerability/CVE-2024-24549

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24549/
Summaries are generated and may contain mistakes; the official description above is the record.
