# CVE-2024-24556: XSS in @urql/next


- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 30 Jan 2024
- **Updated:** 29 May 2025
- **Also known as:** GHSA-qhjf-hm5j-335w

## What is CVE-2024-24556?

CVE-2024-24556 is a high-severity vulnerability in urql-graphql urql, published on 30 Jan 2024. 

### Official description

urql is a GraphQL client that exposes a set of helpers for several frameworks.  The `@urql/next` package is vulnerable to XSS. To exploit this an attacker would need to ensure that the response returns `html` tags and that the web-application is using streamed responses (non-RSC). This vulnerability is due to improper escaping of html-like characters in the response-stream. To fix this vulnerability upgrade to version 1.1.1

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-24556?

2 open source packages ship an affected version, including @urql/next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@urql/next` | npm | All versions | 1.1.1 |
| `@urql/next` | npm | All versions | 1.1.1 |

Products: Nearform Urql.

## How do I fix CVE-2024-24556?

Upgrade @urql/next to 1.1.1 or later.

## Is CVE-2024-24556 being exploited?

There is no known exploitation of CVE-2024-24556 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24556 and fix it if it is affected.

What it is: CVE-2024-24556 is a high-severity vulnerability in urql-graphql urql, published on 30 Jan 2024. 
Exploitation: There is no known exploitation of CVE-2024-24556 in the wild and no public exploit code.

Affected packages and fixed versions:
- @urql/next (npm): affected all versions; fixed in 1.1.1
- @urql/next (npm): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24556/ (Markdown: https://insights.sbomify.com/CVE-2024-24556/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24556
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24556
- OSV: https://osv.dev/vulnerability/CVE-2024-24556

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24556/
Summaries are generated and may contain mistakes; the official description above is the record.
