{"answers":{"affected":"2 open source packages ship an affected version, including @tanstack/react-query-next-experimental. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-24558 in the wild and no public exploit code.","fix":"Upgrade @tanstack/react-query-next-experimental to 5.18.0 or later.","what":"CVE-2024-24558 is a high-severity cross-site scripting vulnerability in TanStack query, published on 30 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-24558 and fix it if it is affected.\n\nWhat it is: CVE-2024-24558 is a high-severity cross-site scripting vulnerability in TanStack query, published on 30 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-24558 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @tanstack/react-query-next-experimental (npm): affected from 5.0.0; fixed in 5.18.0\n- @tanstack/react-query-next-experimental (npm): affected from 5.0.0; fixed in 5.18.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-24558/ (Markdown: https://insights.sbomify.com/CVE-2024-24558/index.md)","id":"CVE-2024-24558","markdown":"https://insights.sbomify.com/CVE-2024-24558/index.md","name":"CVE-2024-24558","record":{"aliases":["GHSA-997g-27x8-43rf"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"React state management library","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in the browser via malicious input in the TanStack Query Next.js experimental package.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"react-query-next-experimental","vendor":"tanstack"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"TanStack Query supplies asynchronous state management, server-state utilities and data fetching for the web.  The `@tanstack/react-query-next-experimental` NPM package is vulnerable to a cross-site scripting vulnerability. To exploit this, an attacker would need to either inject malicious input or arrange to have malicious input be returned from an endpoint. To fix this issue, please update to version 5.18.0 or later.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"react-query-streamed-hydration xss","id":"CVE-2024-24558","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Vyper SHA3 code generation bug","id":"CVE-2024-24559"},"packages":[{"ecosystem":"npm","fixed":["5.18.0"],"introduced":["5.0.0"],"last_affected":[],"package":"@tanstack/react-query-next-experimental","purl":null,"source":"GHSA-997g-27x8-43rf"},{"ecosystem":"npm","fixed":["5.18.0"],"introduced":["5.0.0"],"last_affected":[],"package":"@tanstack/react-query-next-experimental","purl":"pkg:npm/%40tanstack/react-query-next-experimental","source":"GHSA-997g-27x8-43rf"}],"prev":{"headline":"Moby classic builder cache poisoning","id":"CVE-2024-24557"},"products":["query"],"published":"2024-01-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-23","vendors":["TanStack"]},"summary":"An attacker can execute arbitrary scripts in the browser via malicious input in the TanStack Query Next.js experimental package.","url":"https://insights.sbomify.com/CVE-2024-24558/"}