# CVE-2024-24558: react-query-streamed-hydration xss

> An attacker can execute arbitrary scripts in the browser via malicious input in the TanStack Query Next.js experimental package.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jan 2024
- **Updated:** 23 Aug 2024
- **Also known as:** GHSA-997g-27x8-43rf

## What is CVE-2024-24558?

CVE-2024-24558 is a high-severity cross-site scripting vulnerability in TanStack query, published on 30 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

TanStack Query supplies asynchronous state management, server-state utilities and data fetching for the web.  The `@tanstack/react-query-next-experimental` NPM package is vulnerable to a cross-site scripting vulnerability. To exploit this, an attacker would need to either inject malicious input or arrange to have malicious input be returned from an endpoint. To fix this issue, please update to version 5.18.0 or later.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-24558?

2 open source packages ship an affected version, including @tanstack/react-query-next-experimental. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@tanstack/react-query-next-experimental` | npm | From 5.0.0 | 5.18.0 |
| `@tanstack/react-query-next-experimental` | npm | From 5.0.0 | 5.18.0 |

Products: Tanstack React-Query-Next-Experimental.

## How do I fix CVE-2024-24558?

Upgrade @tanstack/react-query-next-experimental to 5.18.0 or later.

## Is CVE-2024-24558 being exploited?

There is no known exploitation of CVE-2024-24558 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24558 and fix it if it is affected.

What it is: CVE-2024-24558 is a high-severity cross-site scripting vulnerability in TanStack query, published on 30 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-24558 in the wild and no public exploit code.

Affected packages and fixed versions:
- @tanstack/react-query-next-experimental (npm): affected from 5.0.0; fixed in 5.18.0
- @tanstack/react-query-next-experimental (npm): affected from 5.0.0; fixed in 5.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24558/ (Markdown: https://insights.sbomify.com/CVE-2024-24558/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24558
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24558
- OSV: https://osv.dev/vulnerability/CVE-2024-24558

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24558/
Summaries are generated and may contain mistakes; the official description above is the record.
