# CVE-2024-24561: Vyper bounds check on built-in `slice()` function can be overflowed

> Attackers can exploit an integer overflow in Vyper's slice bounds check to access or corrupt out-of-bounds storage, memory, or calldata.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Feb 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-9x7f-gwxq-6f2c, PYSEC-2024-149

## What is CVE-2024-24561?

CVE-2024-24561 is a critical vulnerability in vyperlang vyper, published on 1 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. In versions 0.3.10 and earlier, the bounds check for slices does not account for the ability for start + length to overflow when the values aren't literals. If a slice() function uses a non-literal argument for the start or length variable, this creates the ability for an attacker to overflow the bounds check. This issue can be used to do OOB access to storage, memory or calldata addresses. It can also be used to corrupt the length slot of the respective array.

Weakness: CWE-787 (Out-of-bounds Write), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2024-24561?

3 open source packages ship an affected version, including vyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | All versions | 0.4.0 |
| `vyper` | PyPI | All versions | 0.4.0 |
| `vyper` | PyPI | All versions | 0.4.0b1 |

Products: Vyperlang Vyper.

## How do I fix CVE-2024-24561?

Upgrade vyper to a fixed version for your release line: 0.4.0 or 0.4.0b1.

## Is CVE-2024-24561 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-24561 exists.

## Other vulnerabilities in vyperlang vyper

- [CVE-2024-24563](https://insights.sbomify.com/CVE-2024-24563/): Vyper array negative index vulnerability (critical 9.8)
- [CVE-2023-39363](https://insights.sbomify.com/CVE-2023-39363/): Vyper incorrectly allocated named re-entrancy locks (critical 9.1)
- [CVE-2022-24845](https://insights.sbomify.com/CVE-2022-24845/): Integer bounds error in Vyper (high 8.8)
- [CVE-2022-29255](https://insights.sbomify.com/CVE-2022-29255/): Multiple evaluation of contract address in call in vyper (high 8.2)
- [CVE-2023-42443](https://insights.sbomify.com/CVE-2023-42443/): Vyper vulnerable to memory corruption in certain builtins utilizing `msize` (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24561 and fix it if it is affected.

What it is: CVE-2024-24561 is a critical vulnerability in vyperlang vyper, published on 1 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-24561 exists.

Affected packages and fixed versions:
- vyper (PyPI): affected all versions; fixed in 0.4.0
- vyper (PyPI): affected all versions; fixed in 0.4.0
- vyper (PyPI): affected all versions; fixed in 0.4.0b1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24561/ (Markdown: https://insights.sbomify.com/CVE-2024-24561/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24561
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24561
- OSV: https://osv.dev/vulnerability/CVE-2024-24561

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24561/
Summaries are generated and may contain mistakes; the official description above is the record.
