{"answers":{"affected":"2 open source packages ship an affected version, including @lobehub/chat. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-24566 in the wild and no public exploit code.","fix":"Upgrade @lobehub/chat to 0.122.4 or later.","what":"CVE-2024-24566 is a medium-severity missing authorization vulnerability in lobehub lobe-chat, published on 31 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-24566 and fix it if it is affected.\n\nWhat it is: CVE-2024-24566 is a medium-severity missing authorization vulnerability in lobehub lobe-chat, published on 31 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-24566 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @lobehub/chat (npm): affected all versions; fixed in 0.122.4\n- @lobehub/chat (npm): affected all versions; fixed in 0.122.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-24566/ (Markdown: https://insights.sbomify.com/CVE-2024-24566/index.md)","id":"CVE-2024-24566","markdown":"https://insights.sbomify.com/CVE-2024-24566/index.md","name":"CVE-2024-24566","record":{"aliases":["GHSA-pf55-fj96-xf37"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Lobe Chat framework","requires_auth":"none","summary":"Attackers can bypass password protection to access plugins in Lobe Chat when deployed with the ACCESS_CODE option.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"lobe_chat","vendor":"lobehub"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"Lobe Chat is a chatbot framework that supports speech synthesis, multimodal, and extensible Function Call plugin system. When the application is password-protected (deployed with the `ACCESS_CODE` option), it is possible to access plugins without proper authorization (without password). This vulnerability is patched in 0.122.4.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Lobe Chat unauthorized access to plugins","id":"CVE-2024-24566","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"raw_call `value=` kwargs not disabled for static and delegate calls","id":"CVE-2024-24567"},"packages":[{"ecosystem":"npm","fixed":["0.122.4"],"introduced":["0"],"last_affected":[],"package":"@lobehub/chat","purl":null,"source":"GHSA-pf55-fj96-xf37"},{"ecosystem":"npm","fixed":["0.122.4"],"introduced":["0"],"last_affected":[],"package":"@lobehub/chat","purl":"pkg:npm/%40lobehub/chat","source":"GHSA-pf55-fj96-xf37"}],"prev":{"headline":"CrateDB database has an arbitrary file read vulnerability","id":"CVE-2024-24565"},"products":["lobe-chat"],"published":"2024-01-31","related":[{"cvss_score":9,"headline":"Lobe Chat has insufficient fix for GHSA-mxhq-xw3g-rphc (CVE-2024-32964)","id":"CVE-2024-47066","kev_date_added":null,"published":"2024-09-23"},{"cvss_score":9,"headline":"lobe-chat `/api/proxy` endpoint Server-Side Request Forgery vulnerability","id":"CVE-2024-32964","kev_date_added":null,"published":"2024-05-10"},{"cvss_score":8.1,"headline":"ssrf vulnerability in lobe-chat","id":"CVE-2024-32965","kev_date_added":null,"published":"2024-11-26"},{"cvss_score":6.8,"headline":"Lobe Chat Desktop Vulnerable to Remote Code Execution via XSS in Chat Messages","id":"CVE-2025-59417","kev_date_added":null,"published":"2025-09-18"},{"cvss_score":5.7,"headline":"API Key Leak in lobe-chat","id":"CVE-2024-37895","kev_date_added":null,"published":"2024-06-17"},{"cvss_score":4.3,"headline":"lobe-chat has an Open Redirect","id":"CVE-2025-59426","kev_date_added":null,"published":"2025-09-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-17","vendors":["lobehub"]},"summary":"Attackers can bypass password protection to access plugins in Lobe Chat when deployed with the ACCESS_CODE option.","url":"https://insights.sbomify.com/CVE-2024-24566/"}