# CVE-2024-24566: Lobe Chat unauthorized access to plugins

> Attackers can bypass password protection to access plugins in Lobe Chat when deployed with the ACCESS_CODE option.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-pf55-fj96-xf37

## What is CVE-2024-24566?

CVE-2024-24566 is a medium-severity missing authorization vulnerability in lobehub lobe-chat, published on 31 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Lobe Chat is a chatbot framework that supports speech synthesis, multimodal, and extensible Function Call plugin system. When the application is password-protected (deployed with the `ACCESS_CODE` option), it is possible to access plugins without proper authorization (without password). This vulnerability is patched in 0.122.4.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-24566?

2 open source packages ship an affected version, including @lobehub/chat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@lobehub/chat` | npm | All versions | 0.122.4 |
| `@lobehub/chat` | npm | All versions | 0.122.4 |

Products: Lobehub Lobe Chat.

## How do I fix CVE-2024-24566?

Upgrade @lobehub/chat to 0.122.4 or later.

## Is CVE-2024-24566 being exploited?

There is no known exploitation of CVE-2024-24566 in the wild and no public exploit code.

## Other vulnerabilities in lobehub lobe-chat

- [CVE-2024-47066](https://insights.sbomify.com/CVE-2024-47066/): Lobe Chat has insufficient fix for GHSA-mxhq-xw3g-rphc (CVE-2024-32964) (critical 9.0)
- [CVE-2024-32964](https://insights.sbomify.com/CVE-2024-32964/): lobe-chat `/api/proxy` endpoint Server-Side Request Forgery vulnerability (critical 9.0)
- [CVE-2024-32965](https://insights.sbomify.com/CVE-2024-32965/): ssrf vulnerability in lobe-chat (high 8.1)
- [CVE-2025-59417](https://insights.sbomify.com/CVE-2025-59417/): Lobe Chat Desktop Vulnerable to Remote Code Execution via XSS in Chat Messages (medium 6.8)
- [CVE-2024-37895](https://insights.sbomify.com/CVE-2024-37895/): API Key Leak in lobe-chat (medium 5.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24566 and fix it if it is affected.

What it is: CVE-2024-24566 is a medium-severity missing authorization vulnerability in lobehub lobe-chat, published on 31 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-24566 in the wild and no public exploit code.

Affected packages and fixed versions:
- @lobehub/chat (npm): affected all versions; fixed in 0.122.4
- @lobehub/chat (npm): affected all versions; fixed in 0.122.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24566/ (Markdown: https://insights.sbomify.com/CVE-2024-24566/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24566
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24566
- OSV: https://osv.dev/vulnerability/CVE-2024-24566

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24566/
Summaries are generated and may contain mistakes; the official description above is the record.
