CVE-2024-24574 phpMyFAQ vulnerable to stored XSS on attachments filename
An attacker can execute arbitrary JavaScript in the victim's browser via a malicious attachment filename in phpMyFAQ.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-24574?
CVE-2024-24574 is a medium-severity cross-site scripting vulnerability in Phpmyfaq Phpmyfaq, published on 5 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. Unsafe echo of filename in phpMyFAQ\phpmyfaq\admin\attachments.php leads to allowed execution of JavaScript code in client side (XSS). This vulnerability has been patched in version 3.2.5.
Which versions are affected by CVE-2024-24574?
2 open source packages ship an affected version, including phpmyfaq/phpmyfaq. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyfaq/phpmyfaq Packagist | All versions | 3.2.5 |
phpmyfaq/phpmyfaq Packagist | All versions | 3.2.5 |
Products include Phpmyfaq Phpmyfaq.
How do I fix CVE-2024-24574?
Upgrade phpmyfaq/phpmyfaq to 3.2.5 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-24574 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-24574 exists.
Other vulnerabilities in Phpmyfaq Phpmyfaq
- CVE-2023-0310 Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq
- CVE-2022-4407 Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq
- CVE-2017-11187 Security feature bypass in n/a
- CVE-2026-76213 phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle
- CVE-2026-76214 phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge
Sources
Also known as GHSA-7m8g-fprr-47fx.