# CVE-2024-24574: phpMyFAQ vulnerable to stored XSS on attachments filename

> An attacker can execute arbitrary JavaScript in the victim's browser via a malicious attachment filename in phpMyFAQ.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Feb 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-7m8g-fprr-47fx

## What is CVE-2024-24574?

CVE-2024-24574 is a medium-severity cross-site scripting vulnerability in Phpmyfaq Phpmyfaq, published on 5 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. Unsafe echo of filename in phpMyFAQ\phpmyfaq\admin\attachments.php leads to allowed execution of JavaScript code in client side (XSS). This vulnerability has been patched in version 3.2.5.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-24574?

2 open source packages ship an affected version, including phpmyfaq/phpmyfaq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 3.2.5 |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 3.2.5 |

Products: Phpmyfaq Phpmyfaq.

## How do I fix CVE-2024-24574?

Upgrade phpmyfaq/phpmyfaq to 3.2.5 or later.

## Is CVE-2024-24574 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-24574 exists.

## Other vulnerabilities in Phpmyfaq Phpmyfaq

- [CVE-2023-0310](https://insights.sbomify.com/CVE-2023-0310/): Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq (critical 9.8)
- [CVE-2022-4407](https://insights.sbomify.com/CVE-2022-4407/): Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq (critical 9.8)
- [CVE-2017-11187](https://insights.sbomify.com/CVE-2017-11187/): Security feature bypass in n/a (critical 9.8)
- [CVE-2026-76213](https://insights.sbomify.com/CVE-2026-76213/): phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle (critical 9.1)
- [CVE-2026-76214](https://insights.sbomify.com/CVE-2026-76214/): phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24574 and fix it if it is affected.

What it is: CVE-2024-24574 is a medium-severity cross-site scripting vulnerability in Phpmyfaq Phpmyfaq, published on 5 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-24574 exists.

Affected packages and fixed versions:
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 3.2.5
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 3.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24574/ (Markdown: https://insights.sbomify.com/CVE-2024-24574/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24574
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24574
- OSV: https://osv.dev/vulnerability/CVE-2024-24574

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24574/
Summaries are generated and may contain mistakes; the official description above is the record.
