CVE-2024-24575 libgit2 is vulnerable to a denial of service attack in `git_revparse_single`
Attackers can cause a denial of service and potentially leak memory in applications using libgit2 by providing crafted inputs to the revparse function.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-24575?
CVE-2024-24575 is a high-severity denial of service vulnerability in libgit2, published on 6 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Using well-crafted inputs to `git_revparse_single` can cause the function to enter an infinite loop, potentially causing a Denial of Service attack in the calling application. The revparse function in `src/libgit2/revparse.c` uses a loop to parse the user-provided spec string. There is an edge-case during parsing that allows a bad actor to force the loop conditions to access arbitrary memory. Potentially, this could also leak memory if the extracted rev spec is reflected back to the attacker. As such, libgit2 versions before 1.4.0 are not affected. Users should upgrade to version 1.6.5 or 1.7.2.
Weakness: CWE-400
Which versions are affected by CVE-2024-24575?
It affects 1 product.
Linux distribution packages (1)
libgit2 openSUSE:Tumbleweed | All versions | 1.7.2-2.1 |
Products include Libgit2 Libgit2.
How do I fix CVE-2024-24575?
Upgrade to a fixed version.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-24575 being exploited?
There is no known exploitation of CVE-2024-24575 in the wild and no public exploit code.
Other vulnerabilities in libgit2
Sources
Also known as AZL-34331, BELL-CVE-2024-24575, DEBIAN-CVE-2024-24575, GHSA-54mf-x2rh-hq9v, JLSEC-2025-185, openSUSE-SU-2024:13675-1.