{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-24575 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-24575 is a high-severity denial of service vulnerability in libgit2, published on 6 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-24575 and fix it if it is affected.\n\nWhat it is: CVE-2024-24575 is a high-severity denial of service vulnerability in libgit2, published on 6 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-24575 in the wild and no public exploit code.\n\nAffected product: libgit2. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-24575/ (Markdown: https://insights.sbomify.com/CVE-2024-24575/index.md)","id":"CVE-2024-24575","markdown":"https://insights.sbomify.com/CVE-2024-24575/index.md","name":"CVE-2024-24575","record":{"aliases":["AZL-34331","BELL-CVE-2024-24575","DEBIAN-CVE-2024-24575","GHSA-54mf-x2rh-hq9v","JLSEC-2025-185","openSUSE-SU-2024:13675-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Git core library","requires_auth":"none","summary":"Attackers can cause a denial of service and potentially leak memory in applications using libgit2 by providing crafted inputs to the revparse function.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"libgit2","vendor":"libgit2"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Using well-crafted inputs to `git_revparse_single` can cause the function to enter an infinite loop, potentially causing a Denial of Service attack in the calling application. The revparse function in `src/libgit2/revparse.c` uses a loop to parse the user-provided spec string. There is an edge-case during parsing that allows a bad actor to force the loop conditions to access arbitrary memory. Potentially, this could also leak memory if the extracted rev spec is reflected back to the attacker. As such, libgit2 versions before 1.4.0 are not affected. Users should upgrade to version 1.6.5 or 1.7.2.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"libgit2 is vulnerable to a denial of service attack in `git_revparse_single`","id":"CVE-2024-24575","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":1,"n_references":9,"next":{"headline":"Rusts's `std::process::Command` did not properly escape arguments of batch files on Windows","id":"CVE-2024-24576"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.7.2-2.1"],"introduced":["0"],"last_affected":[],"package":"libgit2","purl":"pkg:rpm/opensuse/libgit2\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13675-1"}],"prev":{"headline":"phpMyFAQ vulnerable to stored XSS on attachments filename","id":"CVE-2024-24574"},"products":["libgit2"],"published":"2024-02-06","related":[{"cvss_score":8.6,"headline":"libgit2 is vulnerable to arbitrary code execution due to heap corruption in `git_index_add`","id":"CVE-2024-24577","kev_date_added":null,"published":"2024-02-06"},{"cvss_score":5.3,"headline":"libgit2 fails to verify SSH keys by default","id":"CVE-2023-22742","kev_date_added":null,"published":"2023-01-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["libgit2"]},"summary":"Attackers can cause a denial of service and potentially leak memory in applications using libgit2 by providing crafted inputs to the revparse function.","url":"https://insights.sbomify.com/CVE-2024-24575/"}