# CVE-2024-24575: libgit2 is vulnerable to a denial of service attack in `git_revparse_single`

> Attackers can cause a denial of service and potentially leak memory in applications using libgit2 by providing crafted inputs to the revparse function.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2024
- **Updated:** 13 Feb 2025
- **Also known as:** AZL-34331, BELL-CVE-2024-24575, DEBIAN-CVE-2024-24575, GHSA-54mf-x2rh-hq9v, JLSEC-2025-185, openSUSE-SU-2024:13675-1

## What is CVE-2024-24575?

CVE-2024-24575 is a high-severity denial of service vulnerability in libgit2, published on 6 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Using well-crafted inputs to `git_revparse_single` can cause the function to enter an infinite loop, potentially causing a Denial of Service attack in the calling application. The revparse function in `src/libgit2/revparse.c` uses a loop to parse the user-provided spec string. There is an edge-case during parsing that allows a bad actor to force the loop conditions to access arbitrary memory. Potentially, this could also leak memory if the extracted rev spec is reflected back to the attacker. As such, libgit2 versions before 1.4.0 are not affected. Users should upgrade to version 1.6.5 or 1.7.2.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-24575?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libgit2` | openSUSE:Tumbleweed | All versions | 1.7.2-2.1 |

Products: Libgit2 Libgit2.

## How do I fix CVE-2024-24575?

Upgrade to a fixed version.

## Is CVE-2024-24575 being exploited?

There is no known exploitation of CVE-2024-24575 in the wild and no public exploit code.

## Other vulnerabilities in libgit2

- [CVE-2024-24577](https://insights.sbomify.com/CVE-2024-24577/): libgit2 is vulnerable to arbitrary code execution due to heap corruption in `git_index_add` (high 8.6)
- [CVE-2023-22742](https://insights.sbomify.com/CVE-2023-22742/): libgit2 fails to verify SSH keys by default (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24575 and fix it if it is affected.

What it is: CVE-2024-24575 is a high-severity denial of service vulnerability in libgit2, published on 6 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-24575 in the wild and no public exploit code.

Affected product: libgit2. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24575/ (Markdown: https://insights.sbomify.com/CVE-2024-24575/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24575
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24575
- OSV: https://osv.dev/vulnerability/CVE-2024-24575

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24575/
Summaries are generated and may contain mistakes; the official description above is the record.
