# CVE-2024-24590: Allegro AI ClearML vulnerable to deserialization of untrusted data

> A maliciously uploaded artifact in the ClearML client SDK can trigger arbitrary code execution on an end user's system via unsafe deserialization.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Feb 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-cpcw-9h9m-wqw9, PYSEC-2026-1256

## What is CVE-2024-24590?

CVE-2024-24590 is a high-severity unsafe deserialization vulnerability in Allegro.AI ClearML, published on 6 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Deserialization of untrusted data can occur in versions 0.17.0 to 1.14.2 of the client SDK of Allegro AI’s ClearML platform, enabling a maliciously uploaded artifact to run arbitrary code on an end user’s system when interacted with.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2024-24590?

3 open source packages ship an affected version, including clearml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `clearml` | PyPI | From 0.17.0 to 1.14.1 | None |
| `clearml` | PyPI | From 0.17.0 to 1.14.1 | None |
| `clearml` | PyPI | From 0.17.0 | 1.14.3rc0 |

Products: Clear Clearml.

## How do I fix CVE-2024-24590?

Upgrade clearml to 1.14.3rc0 or later.

## Is CVE-2024-24590 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-24590 exists.

Public exploit code:

- CVE-2024-24590 ClearML RCE&CMD POC (github_poc): https://github.com/diegogarciayala/CVE-2024-24590-ClearML-RCE-CMD-POC
- Proof of concept for CVE-2024-24590 (github_poc): https://github.com/OxyDeV2/ClearML-CVE-2024-24590
- CVE-2024-24590 – ClearML RCE via unsafe pickle artifact deserialization (0.17.0–1.14.2) (github_poc): https://github.com/rippsec/CVE-2024-24590-ClearML-RCE-Exploit
- With this script you can exploit the CVE-2024-24590 (github_poc): https://github.com/sviim/ClearML-CVE-2024-24590-RCE
- Deserialization of untrusted data can occur in versions 0.17.0 to 1.14.2 of the client SDK of Allegro AI’s ClearML platform, enabling a maliciously uploaded artifact to run arbitrary code on an end user’s system when interacted with. (github_poc): https://github.com/junnythemarksman/CVE-2024-24590
- Created this exploit for the Hack The Box machine, Blurry. (github_poc): https://github.com/j3r1ch0123/CVE-2024-24590

## Other vulnerabilities in Allegro.AI ClearML

- [CVE-2024-24594](https://insights.sbomify.com/CVE-2024-24594/): Cross-site scripting in ClearML (critical 9.9)
- [CVE-2024-24592](https://insights.sbomify.com/CVE-2024-24592/): Missing authorization in ClearML (critical 9.8)
- [CVE-2024-24593](https://insights.sbomify.com/CVE-2024-24593/): Cross-site request forgery in ClearML (critical 9.6)
- [CVE-2024-24591](https://insights.sbomify.com/CVE-2024-24591/): Allegro AI ClearML path traversal vulnerability (high 8.0)
- [CVE-2024-24595](https://insights.sbomify.com/CVE-2024-24595/): Allegro AI ClearML Stores Credentials in Plaintext in MongoDB Instance (medium 6.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24590 and fix it if it is affected.

What it is: CVE-2024-24590 is a high-severity unsafe deserialization vulnerability in Allegro.AI ClearML, published on 6 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-24590 exists.

Affected packages and fixed versions:
- clearml (PyPI): affected from 0.17.0 up to 1.14.1; no fix listed
- clearml (PyPI): affected from 0.17.0 up to 1.14.1; no fix listed
- clearml (PyPI): affected from 0.17.0; fixed in 1.14.3rc0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24590/ (Markdown: https://insights.sbomify.com/CVE-2024-24590/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24590
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24590
- OSV: https://osv.dev/vulnerability/CVE-2024-24590

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24590/
Summaries are generated and may contain mistakes; the official description above is the record.
