CVE-2024-24680 Django denial-of-service attack in the intcomma template filter

High 7.5 Published Updated

Attackers can cause denial of service in Django applications by passing very long strings to the intcomma template filter.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-24680?

CVE-2024-24680 is a high-severity denial of service vulnerability in Djangoproject Django, published on 6 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was discovered in Django 3.2 before 3.2.24, 4.2 before 4.2.10, and Django 5.0 before 5.0.2. The intcomma template filter was subject to a potential denial-of-service attack when used with very long strings.

Which versions are affected by CVE-2024-24680?

8 open source packages ship an affected version, including django and Django. It affects 1 product.

PackageAffectedFixed in
django BitnamiFrom 3.2.03.2.24, 4.2.10, 5.0.2
django PyPIFrom 3.23.2.24, 4.2.10, 5.0.2
django PyPIFrom 3.23.2.24
django PyPIFrom 4.24.2.10
django PyPIFrom 5.05.0.2
Django PyPIFrom 3.23.2.24
2 more packages
Django PyPIFrom 4.24.2.10
Django PyPIFrom 5.05.0.2
Linux distribution packages (3)
python-django Red Hat:openstack:17.1::el9All versions0:2.2.24-8.el9ost
python3-django Red Hat:openstack:17.1::el9All versions0:2.2.24-8.el9ost
python-Django openSUSE:TumbleweedAll versions4.2.10-1.1

Products include Djangoproject Django.

How do I fix CVE-2024-24680?

Upgrade django to a fixed version for your release line: 3.2.24, 4.2.10 or 5.0.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-24680 being exploited?

There is no known exploitation of CVE-2024-24680 in the wild and no public exploit code.

All Djangoproject Django vulnerabilities

Sources

Also known as BIT-django-2024-24680, CLSA-2025-1753747897, CLSA-2025-1757031092, DEBIAN-CVE-2024-24680, GHSA-xxj9-f6rv-m3x4, OESA-2024-1163 and 10 more.

Is CVE-2024-24680 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free