{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.hop:hop. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-24683 in the wild and no public exploit code.","fix":"Upgrade org.apache.hop:hop to 2.8.0 or later.","what":"CVE-2024-24683 is a medium-severity cross-site scripting vulnerability in Apache Hop Engine, published on 19 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-24683 and fix it if it is affected.\n\nWhat it is: CVE-2024-24683 is a medium-severity cross-site scripting vulnerability in Apache Hop Engine, published on 19 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-24683 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.hop:hop (Maven): affected all versions; fixed in 2.8.0\n- org.apache.hop:hop (Maven): affected all versions; fixed in 2.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-24683/ (Markdown: https://insights.sbomify.com/CVE-2024-24683/index.md)","id":"CVE-2024-24683","markdown":"https://insights.sbomify.com/CVE-2024-24683/index.md","name":"CVE-2024-24683","record":{"aliases":["GHSA-f6g6-pjgc-5cj5"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Hop Engine","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts via unescaped ID parameters in Hop Server HTML output, potentially leading to code execution.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"hop_engine","vendor":"apache"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Improper Input Validation vulnerability in Apache Hop Engine.This issue affects Apache Hop Engine: before 2.8.0.\n\nUsers are recommended to upgrade to version 2.8.0, which fixes the issue.\n\nWhen Hop Server writes links to the PrepareExecutionPipelineServlet page one of the parameters provided to the user was not properly escaped.\nThe variable not properly escaped is the \"id\", which is not directly accessible by users creating pipelines making the risk of exploiting this low.\n\nThis issue only affects users using the Hop Server component and does not directly affect the client.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Hop Engine: ID isn't escaped when generating HTML","id":"CVE-2024-24683","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Memory corruption in libigl","id":"CVE-2024-24684"},"packages":[{"ecosystem":"Maven","fixed":["2.8.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.hop:hop","purl":null,"source":"GHSA-f6g6-pjgc-5cj5"},{"ecosystem":"Maven","fixed":["2.8.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.hop:hop","purl":"pkg:maven/org.apache.hop/hop","source":"GHSA-f6g6-pjgc-5cj5"}],"prev":{"headline":"Hardcoded credentials in n/a","id":"CVE-2024-24681"},"products":["Apache Hop Engine"],"published":"2024-03-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"An attacker can inject malicious scripts via unescaped ID parameters in Hop Server HTML output, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2024-24683/"}