# CVE-2024-24683: Apache Hop Engine: ID isn't escaped when generating HTML

> An attacker can inject malicious scripts via unescaped ID parameters in Hop Server HTML output, potentially leading to code execution.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-f6g6-pjgc-5cj5

## What is CVE-2024-24683?

CVE-2024-24683 is a medium-severity cross-site scripting vulnerability in Apache Hop Engine, published on 19 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Input Validation vulnerability in Apache Hop Engine.This issue affects Apache Hop Engine: before 2.8.0.

Users are recommended to upgrade to version 2.8.0, which fixes the issue.

When Hop Server writes links to the PrepareExecutionPipelineServlet page one of the parameters provided to the user was not properly escaped.
The variable not properly escaped is the "id", which is not directly accessible by users creating pipelines making the risk of exploiting this low.

This issue only affects users using the Hop Server component and does not directly affect the client.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-24683?

2 open source packages ship an affected version, including org.apache.hop:hop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hop:hop` | Maven | All versions | 2.8.0 |
| `org.apache.hop:hop` | Maven | All versions | 2.8.0 |

Products: Apache Hop Engine.

## How do I fix CVE-2024-24683?

Upgrade org.apache.hop:hop to 2.8.0 or later.

## Is CVE-2024-24683 being exploited?

There is no known exploitation of CVE-2024-24683 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24683 and fix it if it is affected.

What it is: CVE-2024-24683 is a medium-severity cross-site scripting vulnerability in Apache Hop Engine, published on 19 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-24683 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hop:hop (Maven): affected all versions; fixed in 2.8.0
- org.apache.hop:hop (Maven): affected all versions; fixed in 2.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24683/ (Markdown: https://insights.sbomify.com/CVE-2024-24683/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24683
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24683
- OSV: https://osv.dev/vulnerability/CVE-2024-24683

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24683/
Summaries are generated and may contain mistakes; the official description above is the record.
