{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-2469 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-2469 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-2469 is a high-severity vulnerability in Github Enterprise Server, published on 20 Mar 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-2469 and fix it if it is affected.\n\nWhat it is: CVE-2024-2469 is a high-severity vulnerability in Github Enterprise Server, published on 20 Mar 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-2469 in the wild and no public exploit code.\n\nAffected product: Github Enterprise Server. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-2469/ (Markdown: https://insights.sbomify.com/CVE-2024-2469/index.md)","id":"CVE-2024-2469","markdown":"https://insights.sbomify.com/CVE-2024-2469/index.md","name":"CVE-2024-2469","record":{"aliases":["GHSA-v7f6-g4pv-2qgj"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"GitHub Enterprise Server","requires_auth":"high_privilege","summary":"Administrators can gain SSH root access via remote code execution, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_P","cpe":[{"product":"enterprise_server","vendor":"github"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"An attacker with an Administrator role in GitHub Enterprise Server could gain SSH root access via remote code execution. This vulnerability affected GitHub Enterprise Server version 3.8.0 and above and was fixed in version 3.8.17, 3.9.12, 3.10.9, 3.11.7 and 3.12.1. This vulnerability was reported via the GitHub Bug Bounty program.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Remote Code Execution in GitHub Enterprise Server Allowed Administrators to gain SSH access to the appliance","id":"CVE-2024-2469","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"github:enterprise_server","products":["github:enterprise_server"],"type":"privilege_escalation","year":"2024"},"n_packages":0,"n_references":5,"next":{"headline":"Simple Ajax Chat \u003c 20240412 - Admin+ Stored XSS","id":"CVE-2024-2470"},"packages":[],"prev":{"headline":"EmbedPress \u003c= 3.9.12 - Authenticated(Contributor+) Stored Cross-Site Scripting via Widget Attribute","id":"CVE-2024-2468"},"products":["Enterprise Server"],"published":"2024-03-20","related":[{"cvss_score":10,"headline":"Auth bypass in Enterprise Server","id":"CVE-2024-4985","kev_date_added":null,"published":"2024-05-20"},{"cvss_score":9.8,"headline":"Missing authorization in GitHub Enterprise Server","id":"CVE-2022-23739","kev_date_added":null,"published":"2023-01-17"},{"cvss_score":9.8,"headline":"Improper Limitation of a Pathname to a Restricted Directory in GitHub Enterprise Server leading to RCE","id":"CVE-2022-46255","kev_date_added":null,"published":"2022-12-14"},{"cvss_score":9.8,"headline":"Improper access control in GitHub Enterprise Server allows self-hosted runners to execute outside their control group","id":"CVE-2021-22869","kev_date_added":null,"published":"2021-09-24"},{"cvss_score":9.5,"headline":"Auth bypass in Enterprise Server","id":"CVE-2024-9487","kev_date_added":null,"published":"2024-10-10"},{"cvss_score":9.5,"headline":"Auth bypass in GitHub Enterprise Server","id":"CVE-2024-6800","kev_date_added":null,"published":"2024-08-20"},{"cvss_score":9.3,"headline":"GitHub Enterprise Server notebook viewer vulnerable to Server-side request forgery","id":"CVE-2026-77987","kev_date_added":null,"published":"2026-09-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-10","vendors":["GitHub"]},"summary":"Administrators can gain SSH root access via remote code execution, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2024-2469/"}