CVE-2024-24746 Apache NimBLE: Denial of service in NimBLE Bluetooth stack

High 7.5 Published Updated

A specially crafted GATT operation can cause an infinite loop in the Apache NimBLE Bluetooth stack, leading to denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-24746?

CVE-2024-24746 is a high-severity denial of service vulnerability in Apache NimBLE, published on 6 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in Apache NimBLE. 

Specially crafted GATT operation can cause infinite loop in GATT server leading to denial of service in Bluetooth stack or device.

This issue affects Apache NimBLE: through 1.6.0. Users are recommended to upgrade to version 1.7.0, which fixes the issue.

Weakness: CWE-835

Which versions are affected by CVE-2024-24746?

It affects 1 product.

Products include Apache Nimble.

How do I fix CVE-2024-24746?

No fix has been published for CVE-2024-24746 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-24746 being exploited?

There is no known exploitation of CVE-2024-24746 in the wild and no public exploit code.

Sources

Also known as GHSA-wpv3-6qr5-9rmx.

Is CVE-2024-24746 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free