# CVE-2024-24750: Backpressure request ignored in fetch() in Undici

> Attackers can cause memory leaks and denial of service by sending requests where the response body is not consumed, affecting Node.js applications using Undici.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Feb 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-9f24-jqhm-jfcw, UBUNTU-CVE-2024-24750

## What is CVE-2024-24750?

CVE-2024-24750 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 16 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Undici is an HTTP/1.1 client, written from scratch for Node.js. In affected versions calling `fetch(url)` and not consuming the incoming body ((or consuming it very slowing) will lead to a memory leak. This issue has been addressed in version 6.6.1. Users are advised to upgrade. Users unable to upgrade should make sure to always consume the incoming body.

Weakness: CWE-401 (Missing Release of Memory after Effective Lifetime), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-24750?

2 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 6.0.0 | 6.6.1 |
| `undici` | npm | From 6.0.0 | 6.6.1 |

Products: Nodejs Undici.

## How do I fix CVE-2024-24750?

Upgrade undici to 6.6.1 or later.

## Is CVE-2024-24750 being exploited?

There is no known exploitation of CVE-2024-24750 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24750 and fix it if it is affected.

What it is: CVE-2024-24750 is a medium-severity denial of service vulnerability in Nodejs Undici, published on 16 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-24750 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 6.0.0; fixed in 6.6.1
- undici (npm): affected from 6.0.0; fixed in 6.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24750/ (Markdown: https://insights.sbomify.com/CVE-2024-24750/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24750
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24750
- OSV: https://osv.dev/vulnerability/CVE-2024-24750

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24750/
Summaries are generated and may contain mistakes; the official description above is the record.
