# CVE-2024-24768: 1Panel set-cookie is missing the Secure keyword

> Attackers can intercept session cookies sent over HTTP due to missing Secure flag, potentially leading to session hijacking.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Feb 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-9xfw-jjq2-7v8h, GO-2024-2531

## What is CVE-2024-24768?

CVE-2024-24768 is a medium-severity vulnerability in 1Panel-dev 1Panel, published on 5 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

1Panel is an open source Linux server operation and maintenance management panel. The HTTPS cookie that comes with the panel does not have the Secure keyword, which may cause the cookie to be sent in plain text if accessed using HTTP. This issue has been patched in version 1.9.6.

Weakness: CWE-311 (Missing Encryption of Sensitive Data), CWE-315 (Cleartext Storage of Sensitive Information in a Cookie)

## Which versions are affected by CVE-2024-24768?

3 open source packages ship an affected version, including github.com/1Panel-dev/1Panel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/1Panel-dev/1Panel` | Go | All versions | 1.9.6 |
| `github.com/1Panel-dev/1Panel` | Go | All versions | 1.9.6 |
| `github.com/1Panel-dev/1Panel` | Go | All versions | 1.9.6 |

Products: Fit2cloud 1panel.

## How do I fix CVE-2024-24768?

Upgrade github.com/1Panel-dev/1Panel to 1.9.6 or later.

## Is CVE-2024-24768 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-24768 exists.

## Other vulnerabilities in 1Panel-dev 1Panel

- [CVE-2024-39911](https://insights.sbomify.com/CVE-2024-39911/): 1Panel SQL injection (critical 10.0)
- [CVE-2024-39907](https://insights.sbomify.com/CVE-2024-39907/): a sqlinjection in 1Panel (critical 9.8)
- [CVE-2025-56413](https://insights.sbomify.com/CVE-2025-56413/): Command injection in n/a (high 8.8)
- [CVE-2025-54424](https://insights.sbomify.com/CVE-2025-54424/): 1Panel Agent Bypasses Certificate Verification Leading to Arbitrary Command Execution (high 8.1)
- [CVE-2025-66507](https://insights.sbomify.com/CVE-2025-66507/): 1Panel – CAPTCHA Bypass via Client-Controlled Flag (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24768 and fix it if it is affected.

What it is: CVE-2024-24768 is a medium-severity vulnerability in 1Panel-dev 1Panel, published on 5 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-24768 exists.

Affected packages and fixed versions:
- github.com/1Panel-dev/1Panel (Go): affected all versions; fixed in 1.9.6
- github.com/1Panel-dev/1Panel (Go): affected all versions; fixed in 1.9.6
- github.com/1Panel-dev/1Panel (Go): affected all versions; fixed in 1.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24768/ (Markdown: https://insights.sbomify.com/CVE-2024-24768/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24768
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24768
- OSV: https://osv.dev/vulnerability/CVE-2024-24768

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24768/
Summaries are generated and may contain mistakes; the official description above is the record.
