# CVE-2024-24770: Username timing attack on recover password/MFA token in vantage6

> Attackers can enumerate valid usernames in vantage6 by observing timing differences in password and MFA recovery API responses.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Mar 2024
- **Updated:** 26 Aug 2024
- **Also known as:** GHSA-5h3x-6gwf-73jm, PYSEC-2026-2005

## What is CVE-2024-24770?

CVE-2024-24770 is a medium-severity vulnerability in vantage6, published on 14 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vantage6 is an open source framework built to enable, manage and deploy privacy enhancing technologies like Federated Learning and Multi-Party Computation. Much like GHSA-45gq-q4xh-cp53, it is possible to find which usernames exist in vantage6 by calling the API routes `/recover/lost` and `/2fa/lost`. These routes send emails to users if they have lost their password or MFA token. This issue has been addressed in commit `aecfd6d0e` and is expected to ship in subsequent releases. Users are advised to upgrade as soon as a new release is available. There are no known workarounds for this vulnerability.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization), CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2024-24770?

3 open source packages ship an affected version, including vantage6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vantage6` | PyPI | All versions | 4.3.0 |
| `vantage6` | PyPI | All versions | 4.3.0 |
| `vantage6` | PyPI | All versions | 4.3.0 |

Products: Vantage6 Vantage6.

## How do I fix CVE-2024-24770?

Upgrade vantage6 to 4.3.0 or later.

## Is CVE-2024-24770 being exploited?

There is no known exploitation of CVE-2024-24770 in the wild and no public exploit code.

## Other vulnerabilities in vantage6

- [CVE-2024-21649](https://insights.sbomify.com/CVE-2024-21649/): Remote code execution (high 8.8)
- [CVE-2023-23929](https://insights.sbomify.com/CVE-2023-23929/): Refresh tokens do not expire in Vantage6 (high 8.8)
- [CVE-2023-47631](https://insights.sbomify.com/CVE-2023-47631/): vantage6 Node accepts non-whitelisted algorithms from malicious server (high 7.2)
- [CVE-2024-21653](https://insights.sbomify.com/CVE-2024-21653/): vantage6 insecure SSH configuration for node and server containers (medium 6.5)
- [CVE-2023-22738](https://insights.sbomify.com/CVE-2023-22738/): Improper Preservation of Permissions in vantage6 (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-24770 and fix it if it is affected.

What it is: CVE-2024-24770 is a medium-severity vulnerability in vantage6, published on 14 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-24770 in the wild and no public exploit code.

Affected packages and fixed versions:
- vantage6 (PyPI): affected all versions; fixed in 4.3.0
- vantage6 (PyPI): affected all versions; fixed in 4.3.0
- vantage6 (PyPI): affected all versions; fixed in 4.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-24770/ (Markdown: https://insights.sbomify.com/CVE-2024-24770/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-24770
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-24770
- OSV: https://osv.dev/vulnerability/CVE-2024-24770

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-24770/
Summaries are generated and may contain mistakes; the official description above is the record.
