CVE-2024-24772 Apache Superset: Improper Neutralisation of custom SQL on embedded context
A guest user can exploit a chart data REST API to send arbitrary SQL statements, potentially leaking information from the underlying analytics database.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-24772?
CVE-2024-24772 is a medium-severity SQL injection vulnerability in Apache Superset, published on 28 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.
Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
Weakness: CWE-89
Which versions are affected by CVE-2024-24772?
6 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache-superset PyPI | All versions | 3.0.4, 3.1.1 |
apache-superset PyPI | All versions | 3.0.4 |
apache-superset PyPI | All versions | 3.0.4 |
apache-superset PyPI | From 3.1.0 | 3.1.1 |
apache-superset PyPI | From 3.1.0 | 3.1.1 |
superset Bitnami | All versions | 4.1.1 |
Products include Apache Superset.
How do I fix CVE-2024-24772?
Upgrade apache-superset to a fixed version for your release line: 3.0.4 or 3.1.1.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2024-24772 being exploited?
There is no known exploitation of CVE-2024-24772 in the wild and no public exploit code.
Other vulnerabilities in Apache Superset
- CVE-2023-27524 Apache Superset Insecure Default Initialization of Resource
- CVE-2022-27479 SQL injection vulnerability in chart data API
- CVE-2018-8021 Deserialization of Untrusted Data in superset
- CVE-2023-49657 Apache Superset: Stored XSS in Dashboard Title and Chart Title
- CVE-2022-43719 Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API
Sources
Also known as BIT-superset-2024-24772, GHSA-m6jm-3v38-76j4, PYSEC-2026-1185.